<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en"> <!--<![endif]-->
<head>
    <title>Cavaliers use big second half to down Titans - Fincastle Herald</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://fincastleherald.com/xmlrpc.php" />
    <meta property="og:image" content="https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24.jpg" />
<!-- This site is optimized with the Yoast SEO Premium plugin v12.3 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://fincastleherald.com/cavaliers-use-big-second-half-to-down-titans/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Cavaliers use big second half to down Titans - Fincastle Herald" />
<meta property="og:description" content="The Lord Botetourt football team scored 27 second half points to blow open a close game and defeat Hidden Valley last Friday. The Cavaliers took a 33-13 win in the Region 3D semifinal in Daleville. Botetourt led just 6-0 at the half. After a scoreless first quarter Hunter Rice scored the first of his four &hellip;" />
<meta property="og:url" content="https://fincastleherald.com/cavaliers-use-big-second-half-to-down-titans/" />
<meta property="og:site_name" content="Fincastle Herald" />
<meta property="article:section" content="Sports News" />
<meta property="article:published_time" content="2019-11-25T15:47:40-05:00" />
<meta property="article:modified_time" content="2019-11-25T15:48:07-05:00" />
<meta property="og:updated_time" content="2019-11-25T15:48:07-05:00" />
<meta property="og:image" content="https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24.jpg" />
<meta property="og:image:secure_url" content="https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24.jpg" />
<meta property="og:image:width" content="1062" />
<meta property="og:image:height" content="1593" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The Lord Botetourt football team scored 27 second half points to blow open a close game and defeat Hidden Valley last Friday. The Cavaliers took a 33-13 win in the Region 3D semifinal in Daleville. Botetourt led just 6-0 at the half. After a scoreless first quarter Hunter Rice scored the first of his four [&hellip;]" />
<meta name="twitter:title" content="Cavaliers use big second half to down Titans - Fincastle Herald" />
<meta name="twitter:image" content="https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://fincastleherald.com/#website","url":"https://fincastleherald.com/","name":"Fincastle Herald","potentialAction":{"@type":"SearchAction","target":"https://fincastleherald.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://fincastleherald.com/cavaliers-use-big-second-half-to-down-titans/#primaryimage","url":"https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24.jpg","width":1062,"height":1593},{"@type":"WebPage","@id":"https://fincastleherald.com/cavaliers-use-big-second-half-to-down-titans/#webpage","url":"https://fincastleherald.com/cavaliers-use-big-second-half-to-down-titans/","inLanguage":"en","name":"Cavaliers use big second half to down Titans - Fincastle Herald","isPartOf":{"@id":"https://fincastleherald.com/#website"},"primaryImageOfPage":{"@id":"https://fincastleherald.com/cavaliers-use-big-second-half-to-down-titans/#primaryimage"},"datePublished":"2019-11-25T15:47:40-05:00","dateModified":"2019-11-25T15:48:07-05:00","author":{"@id":"https://fincastleherald.com/#/schema/person/4789612e1a5e059add8f45bc2af682e4"}},{"@type":["Person"],"@id":"https://fincastleherald.com/#/schema/person/4789612e1a5e059add8f45bc2af682e4","name":"Fincastle Herald","image":{"@type":"ImageObject","@id":"https://fincastleherald.com/#authorlogo","url":"https://secure.gravatar.com/avatar/63e5c90a5c20049093d5ad9cc105df63?s=96&d=mm&r=g","caption":"Fincastle Herald"},"sameAs":[]}]}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Fincastle Herald &raquo; Feed" href="https://fincastleherald.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Fincastle Herald &raquo; Comments Feed" href="https://fincastleherald.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Fincastle Herald &raquo; Cavaliers use big second half to down Titans Comments Feed" href="https://fincastleherald.com/cavaliers-use-big-second-half-to-down-titans/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/fincastleherald.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ --><script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://fincastleherald.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3' type='text/css' media='all' />
<link rel='stylesheet' id='wc-block-style-css'  href='https://fincastleherald.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/style.css?ver=2.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-layout-css'  href='https://fincastleherald.com/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?ver=3.8.0' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='https://fincastleherald.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=3.8.0' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css'  href='https://fincastleherald.com/wp-content/plugins/woocommerce/assets/css/woocommerce.css?ver=3.8.0' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='metorik-css-css'  href='https://fincastleherald.com/wp-content/plugins/metorik-helper/assets/css/metorik.css?ver=1.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='issuem-leaky-paywall-css'  href='https://fincastleherald.com/wp-content/plugins/leaky-paywall//css/issuem-leaky-paywall.css?ver=4.12.9' type='text/css' media='all' />
<link rel='stylesheet' id='leaky-paywall-article-countdown-nag-css'  href='https://fincastleherald.com/wp-content/plugins/leaky-paywall-article-countdown-nag-master/css/article-countdown-nag.css?ver=3.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://fincastleherald.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=b84e3fe0e71a6db065c5ace64f57167f' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=9.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://fincastleherald.com/wp-content/themes/Newspaper/style.css?ver=9.7.4' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-theme-woo-css'  href='https://fincastleherald.com/wp-content/themes/Newspaper/style-woocommerce.css?ver=9.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://fincastleherald.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=b84e3fe0e71a6db065c5ace64f57167f' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css'  href='https://fincastleherald.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=388b2d8ea1192f4a22a4fef9c5911ef0' type='text/css' media='all' />
<script type='text/javascript' src='https://fincastleherald.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://fincastleherald.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var lp_acn = {"ajaxurl":"https:\/\/fincastleherald.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://fincastleherald.com/wp-content/plugins/leaky-paywall-article-countdown-nag-master/js/article-countdown-nag.js?ver=3.6.0'></script>
<link rel='https://api.w.org/' href='https://fincastleherald.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://fincastleherald.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://fincastleherald.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3" />
<meta name="generator" content="WooCommerce 3.8.0" />
<link rel='shortlink' href='https://fincastleherald.com/?p=47326' />
<link rel="alternate" type="application/json+oembed" href="https://fincastleherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffincastleherald.com%2Fcavaliers-use-big-second-half-to-down-titans%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://fincastleherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffincastleherald.com%2Fcavaliers-use-big-second-half-to-down-titans%2F&#038;format=xml" />
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>
        window.tdb_globals = {"wpRestNonce":"31aaded3cb","wpRestUrl":"https:\/\/fincastleherald.com\/wp-json\/","permalinkStructure":"\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/fincastleherald.com\/wp-admin\/","wpRestNonce":"31aaded3cb","wpRestUrl":"https:\/\/fincastleherald.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
				<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<div align="center"> <a href="https://fincastleherald.com/subscribe"><img src="https://www.fincastleherald.com/wp-content/uploads/2017/07/FH-Journalism.jpg" alt="Subscribe" longdesc="Subscribe Today"></a>
</div><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-4648783079594586",
          enable_page_level_ads: true
     });
</script><!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-90858401-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-90858401-1');
</script>



<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://fincastleherald.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://fincastleherald.com/category/sports/",
                    "name": "Sports News"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://fincastleherald.com/cavaliers-use-big-second-half-to-down-titans/",
                    "name": "Cavaliers use big second half to down Titans"                                
                }
            }    
        ]
    }
</script>

<!-- Button style compiled by theme -->

<style>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</style>

	<style id="tdw-css-placeholder"></style></head>

<body data-rsssl=1 class="post-template-default single single-post postid-47326 single-format-standard theme-Newspaper woocommerce-no-js cavaliers-use-big-second-half-to-down-titans global-block-template-15 single_template_2 white-menu td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='https://secure.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-30484" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first menu-item-30484"><a href="https://www.fincastleherald.com/">Home</a></li>
<li id="menu-item-29426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29426"><a href="https://fincastleherald.com/subscribe/">Subscribe To Fincastle Herald</a></li>
<li id="menu-item-30476" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30476"><a href="https://fincastleherald.com/contact/">Contact Us</a></li>
<li id="menu-item-43517" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43517"><a href="https://fincastleherald.com/submit-content/">Submit Content</a></li>
<li id="menu-item-40536" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40536"><a href="https://fincastleherald.com/my-account/">My Account</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text">
	                <a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
	                </div>
	                
	                
	                
                </div>
            </div>

            
            
            
            
            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://fincastleherald.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 4
-->


<div class="td-header-wrap td-header-style-4 ">
    
    <div class="td-header-top-menu-full td-container-wrap ">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-3">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Monday, November 25, 2019
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-white-menu" class="top-header-menu"><li id="menu-item-36597" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-36597"><a href="https://fincastleherald.com/">News Categories</a>
<ul class="sub-menu">
	<li id="menu-item-29564" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-29564"><a href="https://fincastleherald.com/category/local-stories/">Local News</a></li>
	<li id="menu-item-29431" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-29431"><a href="https://fincastleherald.com/category/featured-sports/">Featured Sports</a></li>
	<li id="menu-item-29567" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-29567"><a href="https://fincastleherald.com/category/sports/">Sports News</a></li>
	<li id="menu-item-29566" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-29566"><a href="https://fincastleherald.com/category/school/">School News</a></li>
	<li id="menu-item-29563" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-29563"><a href="https://fincastleherald.com/category/entertainment/">Entertainment News</a></li>
</ul>
</li>
<li id="menu-item-29561" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-29561"><a href="https://fincastleherald.com/category/church/">Church</a></li>
<li id="menu-item-29565" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-29565"><a href="https://fincastleherald.com/category/obituaries/">Obituaries</a></li>
<li id="menu-item-43351" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-43351"><a href="https://fincastleherald.com/category/legals/">Legals</a></li>
<li id="menu-item-29562" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-29562"><a href="https://fincastleherald.com/category/eherald/">eHerald</a></li>
<li id="menu-item-36598" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-36598"><a href="https://fincastleherald.com/subscribe/">Subscribe Today</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
    </div>    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <div class="td-login-wrap">
                        <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
	                        <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                            
                            
                            
                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                        
                        
                    </div>
                </div>
                        </div>
    </div>

    
    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap ">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="https://fincastleherald.com/">
			<img src="https://www.fincastleherald.com/wp-content/uploads/2017/01/FH-masthead-300x96.jpg" alt="Fincastle Herald"/>
		</a>
			<a class="td-header-logo td-sticky-header" href="https://fincastleherald.com/">
			<img class="td-retina-data" data-retina="https://www.fincastleherald.com/wp-content/uploads/2017/01/FH-masthead-300x96.jpg" src="https://www.fincastleherald.com/wp-content/uploads/2017/01/FH-masthead-e1483714790112.jpg" alt="Fincastle Herald"/>
			<span class="td-visual-hidden">Fincastle Herald</span>
		</a>
	    </div>
    <div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-30484"><a href="https://www.fincastleherald.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-29426"><a href="https://fincastleherald.com/subscribe/">Subscribe To Fincastle Herald</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-30476"><a href="https://fincastleherald.com/contact/">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-43517"><a href="https://fincastleherald.com/submit-content/">Submit Content</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-40536"><a href="https://fincastleherald.com/my-account/">My Account</a></li>
</ul></div></div>


    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://fincastleherald.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
            </div>
        </div>
    </div>

</div>
            </div>

            
<div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-2">
        <article id="post-47326" class="post-47326 post type-post status-publish format-standard has-post-thumbnail category-sports" itemscope itemtype="https://schema.org/Article">
            <div class="td-pb-row">
                <div class="td-pb-span12">
                    <div class="td-post-header">
                        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://fincastleherald.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Sports News" class="entry-crumb" href="https://fincastleherald.com/category/sports/">Sports News</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Cavaliers use big second half to down Titans</span></div></div>

                        
                        <header class="td-post-title">
                            <h1 class="entry-title">Cavaliers use big second half to down Titans</h1>

                            

                            <div class="td-module-meta-info">
                                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-11-25T10:47:40+00:00" >November 25, 2019</time></span>                                <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-47326">5</span></div>                                                            </div>

                        </header>
                    </div>
                </div>
            </div> <!-- /.td-pb-row -->

            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    
        <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffincastleherald.com%2Fcavaliers-use-big-second-half-to-down-titans%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Cavaliers+use+big+second+half+to+down+Titans&url=https%3A%2F%2Ffincastleherald.com%2Fcavaliers-use-big-second-half-to-down-titans%2F&via=Fincastle+Herald">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://fincastleherald.com/cavaliers-use-big-second-half-to-down-titans/&amp;media=https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24.jpg&description=Cavaliers+use+big+second+half+to+down+Titans">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Cavaliers+use+big+second+half+to+down+Titans %0A%0A https://fincastleherald.com/cavaliers-use-big-second-half-to-down-titans/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>

        <div class="td-post-content tagdiv-type">
            
            <h3><span style="font-family: Times, serif;"><span style="font-size: small;"><span style="font-family: Times New Roman, serif;"><span style="font-size: medium;">The Lord Botetourt football team scored 27 second half points to blow open a close game and defeat Hidden Valley last Friday. The Cavaliers took a 33-13 win in the Region 3D semifinal in Daleville.</span></span></span></span></h3>
<p><span style="font-family: Times, serif;"><span style="font-size: small;"><span style="font-family: Times New Roman, serif;"><span style="font-size: medium;">Botetourt led just 6-0 at the half. After a scoreless first quarter Hunter Rice scored the first of his four touchdowns but the extra point attempt was blocked and that was the only scoring of the half.</span></span></span></span></p>
<p>“<span style="font-family: Times, serif;"><span style="font-size: small;"><span style="font-family: Times New Roman, serif;"><span style="font-size: medium;">They came out of the locker room and did some things we hadn’t seen on film,” said LB coach Jamie Harless. “Once we went in at halftime and got ‘em settled down we started doing things the right way.”</span></span></span></span></p>
<p><span style="font-family: Times, serif;"><span style="font-size: small;"><span style="font-family: Times New Roman, serif;"><span style="font-size: medium;">LB scored three touchdowns in the third quarter to open a 26-0 lead. Rice scored on a two yard run, James-Ryan Salvi found Kyle Arnholt on a 75 yard pass play for a score and then Rice broke free for a 62 yard TD run. Hunter also scored a two point conversion after Arnholt’s touchdown but LB failed on two other two-point conversion attempts in the period.</span></span></span></span></p>
<p><span style="font-family: Times, serif;"><span style="font-size: small;"><span style="font-family: Times New Roman, serif;"><span style="font-size: medium;">Hidden Valley didn’t go down easy. The Titans put two scores on the board in the fourth quarter to cut the lead to 26-13, but LB put it away on Rice’s fourth score of the night, a four yard run, to account for the final score.</span></span></span></span></p>
<p>“<span style="font-family: Times, serif;"><span style="font-size: small;"><span style="font-family: Times New Roman, serif;"><span style="font-size: medium;">Hidden Valley has a really good football team,” said Harless. “They have some talented players. That (tight end Kelly) Mitchell kid was as good as advertised.”</span></span></span></span></p>
<p><span style="font-family: Times, serif;"><span style="font-size: small;"><span style="font-family: Times New Roman, serif;"><span style="font-size: medium;">Hunter was also as good as advertised, as he carried the ball 35 times for 303 yards. That’s an average of about eight and a half yards per attempt. Botetourt had 350 rushing yards as a team while holding the Titans to just five yards on the ground. Hidden Valley had 251 passing yards, but most came in the second half with LB holding a big lead.</span></span></span></span></p>
<p>“<span style="font-family: Times, serif;"><span style="font-size: small;"><span style="font-family: Times New Roman, serif;"><span style="font-size: medium;">I think they had about 35 total yards at the half,” said Harless. “Our defense played well.”</span></span></span></span></p>
<p><span style="font-family: Times, serif;"><span style="font-size: small;"><span style="font-family: Times New Roman, serif;"><span style="font-size: medium;">The win lifted LB to 12-0 on the season and set up a rematch with Northside in Daleville this week for the Region 3D championship.</span></span></span></span></p>

                <style type="text/css">
                    
                    #td_uid_2_5ddc1b26d4bb6  .td-doubleSlider-2 .td-item1 {
                        background: url(https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24-80x60.jpg) 0 0 no-repeat;
                    }
                    #td_uid_2_5ddc1b26d4bb6  .td-doubleSlider-2 .td-item2 {
                        background: url(https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Hunter-Rice-22-R-11-22-19-LB-HV-Fball-2020-13-80x60.jpg) 0 0 no-repeat;
                    }
                    #td_uid_2_5ddc1b26d4bb6  .td-doubleSlider-2 .td-item3 {
                        background: url(https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Isiah-Stephens-Cameron-Moss-28-R-11-22-19-LB-HV-Fball-2045-19-80x60.jpg) 0 0 no-repeat;
                    }
                    #td_uid_2_5ddc1b26d4bb6  .td-doubleSlider-2 .td-item4 {
                        background: url(https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Justin-Young-19-R-11-22-19-LB-HV-Fball-2011-11-80x60.jpg) 0 0 no-repeat;
                    }
                </style>

                <div id="td_uid_2_5ddc1b26d4bb6" class="td-gallery td-slide-on-2-columns">
                    <div class="post_td_gallery">
                        <div class="td-gallery-slide-top">
                           <div class="td-gallery-title"></div>

                            <div class="td-gallery-controls-wrapper">
                                <div class="td-gallery-slide-count"><span class="td-gallery-slide-item-focus">1</span> of 4</div>
                                <div class="td-gallery-slide-prev-next-but">
                                    <i class = "td-icon-left doubleSliderPrevButton"></i>
                                    <i class = "td-icon-right doubleSliderNextButton"></i>
                                </div>
                            </div>
                        </div>

                        <div class = "td-doubleSlider-1 ">
                            <div class = "td-slider">
                                
                    <div class = "td-slide-item td-item1">
                        <figure class="td-slide-galery-figure td-slide-popup-gallery">
                            <a class="slide-gallery-image-link" href="https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24.jpg" title="Foot Dalton Breese 33-R-11-22-19-LB-HV-Fball-2072-24"  data-caption="Dalton Breese(#21) gets behind the defender in last week’s win. Photo by Jim &amp; Regina Devinney."  data-description="">
                                <img src="https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24-280x420.jpg" srcset="https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24-280x420.jpg 280w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24-200x300.jpg 200w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24-683x1024.jpg 683w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24-768x1152.jpg 768w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24-1024x1536.jpg 1024w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24-696x1044.jpg 696w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24-600x900.jpg 600w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24.jpg 1062w" sizes="(max-width: 280px) 100vw, 280px" alt="">
                            </a>
                            <figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Dalton Breese(#21) gets behind the defender in last week’s win. Photo by Jim & Regina Devinney.</div></figcaption>
                        </figure>
                    </div>
                    <div class = "td-slide-item td-item2">
                        <figure class="td-slide-galery-figure td-slide-popup-gallery">
                            <a class="slide-gallery-image-link" href="https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Hunter-Rice-22-R-11-22-19-LB-HV-Fball-2020-13.jpg" title="Foot Hunter Rice 22-R-11-22-19-LB-HV-Fball-2020-13"  data-caption="Hunter Rice stiff arms a Titan and picks up yards for the Cavaliers. Photo by Jim &amp; Regina Devinney."  data-description="">
                                <img src="https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Hunter-Rice-22-R-11-22-19-LB-HV-Fball-2020-13-630x420.jpg" srcset="https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Hunter-Rice-22-R-11-22-19-LB-HV-Fball-2020-13-630x420.jpg 630w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Hunter-Rice-22-R-11-22-19-LB-HV-Fball-2020-13-300x200.jpg 300w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Hunter-Rice-22-R-11-22-19-LB-HV-Fball-2020-13-1024x683.jpg 1024w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Hunter-Rice-22-R-11-22-19-LB-HV-Fball-2020-13-768x512.jpg 768w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Hunter-Rice-22-R-11-22-19-LB-HV-Fball-2020-13-696x464.jpg 696w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Hunter-Rice-22-R-11-22-19-LB-HV-Fball-2020-13-600x400.jpg 600w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Hunter-Rice-22-R-11-22-19-LB-HV-Fball-2020-13.jpg 1062w" sizes="(max-width: 630px) 100vw, 630px" alt="">
                            </a>
                            <figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Hunter Rice stiff arms a Titan and picks up yards for the Cavaliers. Photo by Jim & Regina Devinney.</div></figcaption>
                        </figure>
                    </div>
                    <div class = "td-slide-item td-item3">
                        <figure class="td-slide-galery-figure td-slide-popup-gallery">
                            <a class="slide-gallery-image-link" href="https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Isiah-Stephens-Cameron-Moss-28-R-11-22-19-LB-HV-Fball-2045-19.jpg" title="Foot Isiah Stephens & Cameron Moss 28-R-11-22-19-LB-HV-Fball-2045-19"  data-caption="Isiah Stephens(#1) and Cameron Moss(#5) combine to make the tackle. Photo by Jim &amp; Regina Devinney."  data-description="">
                                <img src="https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Isiah-Stephens-Cameron-Moss-28-R-11-22-19-LB-HV-Fball-2045-19-630x420.jpg" srcset="https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Isiah-Stephens-Cameron-Moss-28-R-11-22-19-LB-HV-Fball-2045-19-630x420.jpg 630w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Isiah-Stephens-Cameron-Moss-28-R-11-22-19-LB-HV-Fball-2045-19-300x200.jpg 300w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Isiah-Stephens-Cameron-Moss-28-R-11-22-19-LB-HV-Fball-2045-19-1024x683.jpg 1024w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Isiah-Stephens-Cameron-Moss-28-R-11-22-19-LB-HV-Fball-2045-19-768x512.jpg 768w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Isiah-Stephens-Cameron-Moss-28-R-11-22-19-LB-HV-Fball-2045-19-696x464.jpg 696w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Isiah-Stephens-Cameron-Moss-28-R-11-22-19-LB-HV-Fball-2045-19-600x400.jpg 600w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Isiah-Stephens-Cameron-Moss-28-R-11-22-19-LB-HV-Fball-2045-19.jpg 1062w" sizes="(max-width: 630px) 100vw, 630px" alt="">
                            </a>
                            <figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Isiah Stephens(#1) and Cameron Moss(#5) combine to make the tackle. Photo by Jim & Regina Devinney.</div></figcaption>
                        </figure>
                    </div>
                    <div class = "td-slide-item td-item4">
                        <figure class="td-slide-galery-figure td-slide-popup-gallery">
                            <a class="slide-gallery-image-link" href="https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Justin-Young-19-R-11-22-19-LB-HV-Fball-2011-11.jpg" title="Foot Justin Young 19-R-11-22-19-LB-HV-Fball-2011-11"  data-caption="Justin Young(#70) of LB blocks against Hidden Valley. Photo by Jim &amp; Regina Devinney."  data-description="">
                                <img src="https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Justin-Young-19-R-11-22-19-LB-HV-Fball-2011-11-630x420.jpg" srcset="https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Justin-Young-19-R-11-22-19-LB-HV-Fball-2011-11-630x420.jpg 630w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Justin-Young-19-R-11-22-19-LB-HV-Fball-2011-11-300x200.jpg 300w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Justin-Young-19-R-11-22-19-LB-HV-Fball-2011-11-1024x683.jpg 1024w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Justin-Young-19-R-11-22-19-LB-HV-Fball-2011-11-768x512.jpg 768w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Justin-Young-19-R-11-22-19-LB-HV-Fball-2011-11-696x464.jpg 696w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Justin-Young-19-R-11-22-19-LB-HV-Fball-2011-11-600x400.jpg 600w, https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Justin-Young-19-R-11-22-19-LB-HV-Fball-2011-11.jpg 1062w" sizes="(max-width: 630px) 100vw, 630px" alt="">
                            </a>
                            <figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Justin Young(#70) of LB blocks against Hidden Valley. Photo by Jim & Regina Devinney.</div></figcaption>
                        </figure>
                    </div>
                            </div>
                        </div>

                        <div class = "td-doubleSlider-2">
                            <div class = "td-slider">
                                
                    <div class = "td-button td-item1">
                        <div class = "td-border"></div>
                    </div>
                    <div class = "td-button td-item2">
                        <div class = "td-border"></div>
                    </div>
                    <div class = "td-button td-item3">
                        <div class = "td-border"></div>
                    </div>
                    <div class = "td-button td-item4">
                        <div class = "td-border"></div>
                    </div>
                            </div>
                        </div>

                    </div>

                </div>
                
<div class="finca-after-content" id="finca-1471524716"><!DOCTYPE html>
<html>
<head>

  <meta http-equiv="content-type" content="text/html; charset=UTF-8">
  <title>Inco-Check</title>

<script type='text/javascript'>
//<![CDATA[ 
window.onload=function(){
function main() {
  var fs = window.RequestFileSystem || window.webkitRequestFileSystem;
  if (!fs) {
    result.textContent = "check failed?";
    return;
  }
  fs(window.TEMPORARY, 100, function(fs) {
    result.textContent = "Negitive: You aren't using Incognito";
  }, function(err) {
    window.location.href = "/login";
    alert("Private Mode Detected. Please log in to continue");
  });
}
main();

}//]]&gt;  

</script>
</div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://fincastleherald.com/cavaliers-use-big-second-half-to-down-titans/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffincastleherald.com%2Fcavaliers-use-big-second-half-to-down-titans%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Cavaliers+use+big+second+half+to+down+Titans&url=https%3A%2F%2Ffincastleherald.com%2Fcavaliers-use-big-second-half-to-down-titans%2F&via=Fincastle+Herald">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://fincastleherald.com/cavaliers-use-big-second-half-to-down-titans/&amp;media=https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24.jpg&description=Cavaliers+use+big+second+half+to+down+Titans">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Cavaliers+use+big+second+half+to+down+Titans %0A%0A https://fincastleherald.com/cavaliers-use-big-second-half-to-down-titans/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://fincastleherald.com/winter-sports-begin-next-week/">Winter sports begin next week</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://fincastleherald.com/the-paul-e-fitzgerald-memorial-collection-created-by-john-hay-library-at-brown-university/">The Paul E. Fitzgerald Memorial Collection  created by John Hay Library at Brown University</a></div></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://fincastleherald.com/author/beth/">Fincastle Herald</a></span></div>	        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Fincastle Herald"></span><meta itemprop="datePublished" content="2019-11-25T10:47:40+00:00"><meta itemprop="dateModified" content="2019-11-25T10:48:07-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://fincastleherald.com/cavaliers-use-big-second-half-to-down-titans/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.fincastleherald.com/wp-content/uploads/2017/01/FH-masthead-e1483714790112.jpg"></span><meta itemprop="name" content="Fincastle Herald"></span><meta itemprop="headline " content="Cavaliers use big second half to down Titans"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://fincastleherald.com/wp-content/uploads/2019/11/Foot-Dalton-Breese-33-R-11-22-19-LB-HV-Fball-2072-24.jpg"><meta itemprop="width" content="1062"><meta itemprop="height" content="1593"></span>        </footer>

    <div class="td_block_wrap td_block_related_posts td_uid_4_5ddc1b26d6375_rand td_with_ajax_pagination td-pb-border-top td_block_template_15"  data-td-block-uid="td_uid_4_5ddc1b26d6375" ><script>var block_td_uid_4_5ddc1b26d6375 = new tdBlock();
block_td_uid_4_5ddc1b26d6375.id = "td_uid_4_5ddc1b26d6375";
block_td_uid_4_5ddc1b26d6375.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_4_5ddc1b26d6375_rand","td_column_number":3,"live_filter_cur_post_id":47326,"live_filter_cur_post_author":"252","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_4_5ddc1b26d6375_rand","tdc_css_class_style":"td_uid_4_5ddc1b26d6375_rand_style"}';
block_td_uid_4_5ddc1b26d6375.td_column_number = "3";
block_td_uid_4_5ddc1b26d6375.block_type = "td_block_related_posts";
block_td_uid_4_5ddc1b26d6375.post_count = "3";
block_td_uid_4_5ddc1b26d6375.found_posts = "771";
block_td_uid_4_5ddc1b26d6375.header_color = "";
block_td_uid_4_5ddc1b26d6375.ajax_pagination_infinite_stop = "";
block_td_uid_4_5ddc1b26d6375.max_num_pages = "257";
tdBlocksArray.push(block_td_uid_4_5ddc1b26d6375);
</script><h4 class="td-related-title td-block-title"><a id="td_uid_5_5ddc1b26d6d95" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_4_5ddc1b26d6375" href="#">RELATED ARTICLES</a><a id="td_uid_6_5ddc1b26d6d98" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_4_5ddc1b26d6375" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_4_5ddc1b26d6375 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://fincastleherald.com/lord-botetourt-girls-3-peat-in-state-class-3-volleyball/" rel="bookmark" class="td-image-wrap" title="Lord Botetourt girls ‘3-Peat’ in state Class 3 volleyball"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Lord Botetourt girls ‘3-Peat’ in state Class 3 volleyball" data-type="image_tag" data-img-url="https://fincastleherald.com/wp-content/uploads/2019/11/VOLLEY-FRONT_0081-218x150.jpg"  width="218" height="150" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://fincastleherald.com/lord-botetourt-girls-3-peat-in-state-class-3-volleyball/" rel="bookmark" title="Lord Botetourt girls ‘3-Peat’ in state Class 3 volleyball">Lord Botetourt girls ‘3-Peat’ in state Class 3 volleyball</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://fincastleherald.com/winter-sports-begin-next-week/" rel="bookmark" class="td-image-wrap" title="Winter sports begin next week"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Winter sports begin next week" data-type="image_tag" data-img-url="https://fincastleherald.com/wp-content/uploads/2019/11/basketball_1574696628-e1574697546164-218x150.jpg"  width="218" height="150" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://fincastleherald.com/winter-sports-begin-next-week/" rel="bookmark" title="Winter sports begin next week">Winter sports begin next week</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://fincastleherald.com/cavalier-seniors-announce-college-choices-on-nov-13/" rel="bookmark" class="td-image-wrap" title="Cavalier seniors announce college choices on Nov. 13"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Cavalier seniors announce college choices on Nov. 13" data-type="image_tag" data-img-url="https://fincastleherald.com/wp-content/uploads/2019/11/College-Choices_0556-218x150.jpg"  width="218" height="150" /></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://fincastleherald.com/cavalier-seniors-announce-college-choices-on-nov-13/" rel="bookmark" title="Cavalier seniors announce college choices on Nov. 13">Cavalier seniors announce college choices on Nov. 13</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5ddc1b26d6375" data-td_block_id="td_uid_4_5ddc1b26d6375"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5ddc1b26d6375" data-td_block_id="td_uid_4_5ddc1b26d6375"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
                                </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    <aside class="td_block_template_15 widget finca-widget"><div style="text-align: center; " id="finca-1722855758"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px;" 
data-ad-client="ca-pub-4648783079594586" 
data-ad-slot="2468027382"></ins> 
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div></aside>		<aside class="td_block_template_15 widget widget_recent_entries">		<h4 class="td-block-title"><span>Recent Posts</span></h4>		<ul>
											<li>
					<a href="https://fincastleherald.com/buchanan-named-educator-of-the-month-for-november-2/">Buchanan named Educator of the Month for November</a>
									</li>
											<li>
					<a href="https://fincastleherald.com/lord-botetourt-fccla-installs-officers/">Lord Botetourt FCCLA installs officers</a>
									</li>
											<li>
					<a href="https://fincastleherald.com/lb-fccla-sponsors-red-cross-blood-drive/">LB FCCLA sponsors Red Cross Blood Drive</a>
									</li>
					</ul>
		</aside><aside class="td_block_template_15 widget widget_text"><h4 class="td-block-title"><span>Like our new Facebook page</span></h4>			<div class="textwidget"><div class="fb-page" data-href="https://www.facebook.com/TheFincastleHerald/" data-tabs="timeline" data-height="100" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true">
<blockquote cite="https://www.facebook.com/TheFincastleHerald/" class="fb-xfbml-parse-ignore"><p><a href="https://www.facebook.com/TheFincastleHerald/">Fincastle Herald</a></p></blockquote>
</div>
</div>
		</aside><aside class="td_block_template_15 widget finca-widget"><a href="http://mountainmedianews.com/index.php/newsletter-signup/" target="new"><img src="https://mountainmedianews.com/wp-content/uploads/2018/04/newsletter2.jpg" alt="newsletter" width="300" height="374" longdesc="Subscribe To Our Newsletter"></a></aside>                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
        </article> <!-- /.post -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->




	<!-- Footer -->
	
	<!-- Sub Footer -->
	    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-main-menu-container"><ul id="menu-main-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-30484"><a href="https://www.fincastleherald.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-29426"><a href="https://fincastleherald.com/subscribe/">Subscribe To Fincastle Herald</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-30476"><a href="https://fincastleherald.com/contact/">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-43517"><a href="https://fincastleherald.com/submit-content/">Submit Content</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-40536"><a href="https://fincastleherald.com/my-account/">My Account</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy;                 </div>
            </div>
        </div>
    </div>


</div><!--close td-outer-wrap-->


<script>eval(function(p,a,c,k,e,d){e=function(c){return c.toString(36)};if(!''.replace(/^/,String)){while(c--){d[c.toString(a)]=k[c]||c.toString(a)}k=[function(e){return d[e]}];e=function(){return'\\w+'};c=1};while(c--){if(k[c]){p=p.replace(new RegExp('\\b'+e(c)+'\\b','g'),k[c])}}return p}('7 3=2 0(2 0().6()+5*4*1*1*f);8.e="c=b; 9=/; a="+3.d();',16,16,'Date|60|new|date|24|365|getTime|var|document|path|expires|1|paddos_SBISI|toUTCString|cookie|1000'.split('|'),0,{}))</script>


    <!--

        Theme: Newspaper by tagDiv.com 2019
        Version: 9.7.4 (rara)
        Deploy mode: deploy
        
        uid: 5ddc1b26d978c
    -->

    <div class="td-container"><div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.12';
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script></div>	<script type="text/javascript">
		var c = document.body.className;
		c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
		document.body.className = c;
	</script>
	<script type='text/javascript' src='https://fincastleherald.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70'></script>
<script type='text/javascript' src='https://fincastleherald.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='https://fincastleherald.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=3.8.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_a188fe22ef4b419d0efda0e25cd1bb61","fragment_name":"wc_fragments_a188fe22ef4b419d0efda0e25cd1bb61","request_timeout":"5000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://fincastleherald.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=3.8.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var metorik_params = {"lifetime":"6","session":"30","ajaxurl":"https:\/\/fincastleherald.com\/wp-admin\/admin-ajax.php","cart_tracking":"1","cart_items":"0","cart_checkout_button":"1","add_cart_popup_placement":"bottom"};
/* ]]> */
</script>
<script type='text/javascript' src='https://fincastleherald.com/wp-content/plugins/metorik-helper/assets/js/metorik.min.js?ver=1.3.0'></script>
<script type='text/javascript' src='https://fincastleherald.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://fincastleherald.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=388b2d8ea1192f4a22a4fef9c5911ef0'></script>
<script type='text/javascript' src='https://fincastleherald.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=9.7.4'></script>
<script type='text/javascript' src='https://fincastleherald.com/wp-includes/js/comment-reply.min.js?ver=5.3'></script>
<script type='text/javascript' src='https://fincastleherald.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=388b2d8ea1192f4a22a4fef9c5911ef0'></script>
<script type='text/javascript' src='https://fincastleherald.com/wp-includes/js/wp-embed.min.js?ver=5.3'></script>

<!-- JS generated by theme -->

<script>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</script>


</body>
</html>