<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-US"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
<head><style>img.lazy{min-height:1px}</style><link rel="preload" href="https://fincastleherald.com/wp-content/plugins/w3-total-cache/pub/js/lazyload.min.js" as="script">
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' />
    <link rel="profile" href="http://gmpg.org/xfn/11" />
    <link rel="pingback" href="https://fincastleherald.com/xmlrpc.php" />
    <title>Plant swap in Eagle Rock</title>
<meta name='robots' content='max-image-preview:large' />
			<script type="text/javascript">
              var jnews_ajax_url = '/?ajax-request=jnews'
			</script>
			<script type="text/javascript">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</script><link rel="manifest" href="https://fincastleherald.com/wp-json/pwa-for-wp/v2/pwa-manifest-json">
<link rel="apple-touch-icon-precomposed" sizes="192x192" href="https://fincastleherald.com/wp-content/plugins/pwa-for-wp/images/logo.png">
<link rel='dns-prefetch' href='//js.stripe.com' />
<link rel="alternate" type="application/rss+xml" title="Fincastle Herald &raquo; Feed" href="https://fincastleherald.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Fincastle Herald &raquo; Comments Feed" href="https://fincastleherald.com/comments/feed/" />
    <meta name="apple-mobile-web-app-title" content="Plant swap in Eagle Rock">
	<link rel="alternate" type="application/rss+xml" title="Fincastle Herald &raquo; Plant swap in Eagle Rock Comments Feed" href="https://fincastleherald.com/plant-swap-in-eagle-rock/feed/" />
		<script type="text/javascript">
		(function(document,navigator,standalone) {
            // prevents links from apps from oppening in mobile safari
            // this javascript must be the first script in your <head>
            if ((standalone in navigator) && navigator[standalone]) {
                var curnode, location=document.location, stop=/^(a|html)$/i;
                document.addEventListener('click', function(e) {
                    curnode=e.target;
                    while (!(stop).test(curnode.nodeName)) {
                        curnode=curnode.parentNode;
                    }
                    // Condidions to do this only on links to your own app
                    // if you want all links, use if('href' in curnode) instead.
                    if('href' in curnode && ( curnode.href.indexOf('http') || ~curnode.href.indexOf(location.host) ) ) {
                        e.preventDefault();
                        location.href = curnode.href;
                    }
                },false);
            }
        })(document,window.navigator,'standalone');
		</script>
	<!-- fincastleherald.com is managing ads with Advanced Ads --><script id="finca-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
		<link rel="stylesheet" href="https://fincastleherald.com/wp-content/cache/minify/16/5798c.css" media="all" />







<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel="stylesheet" href="https://fincastleherald.com/wp-content/cache/minify/16/2d7e2.css" media="all" />





<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel="stylesheet" href="https://fincastleherald.com/wp-content/cache/minify/16/d1485.css" media="all" />















<link rel='stylesheet' id='google-fonts-1-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic%7CRoboto+Slab%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic&#038;ver=5.9.2' type='text/css' media='all' />
<link rel="stylesheet" href="https://fincastleherald.com/wp-content/cache/minify/16/8fce1.css" media="all" />

<script type="text/javascript">var addToHomeConfig = {animationIn:'fade',animationOut:'fade',startdelay:2000,lifespan:20000,expire:0,touchIcon:false}</script><script  src="https://fincastleherald.com/wp-content/cache/minify/16/28df8.js"></script>



<script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>
/* <![CDATA[ */
var advads_options = {"blog_id":"16","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */
</script>
<script  src="https://fincastleherald.com/wp-content/cache/minify/16/2c6e9.js"></script>

<script type='text/javascript' id='advanced_ads_pro/visitor_conditions-js-extra'>
/* <![CDATA[ */
var advanced_ads_pro_visitor_conditions = {"referrer_cookie_name":"advanced_ads_pro_visitor_referrer","referrer_exdays":"365","page_impr_cookie_name":"advanced_ads_page_impressions","page_impr_exdays":"3650"};
/* ]]> */
</script>
<script  src="https://fincastleherald.com/wp-content/cache/minify/16/5cc27.js"></script>


<script type='text/javascript' id='advanced-ads-pro/cache_busting-js-extra'>
/* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/fincastleherald.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":""};
/* ]]> */
</script>
<script  src="https://fincastleherald.com/wp-content/cache/minify/16/9725e.js"></script>

<link rel="https://api.w.org/" href="https://fincastleherald.com/wp-json/" /><link rel="alternate" type="application/json" href="https://fincastleherald.com/wp-json/wp/v2/posts/79075" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://fincastleherald.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://fincastleherald.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="Mountain Media News 5.9.2 - mountainmedianews.com" />
<link rel='shortlink' href='https://fincastleherald.com/?p=79075' />
<link rel="alternate" type="application/json+oembed" href="https://fincastleherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffincastleherald.com%2Fplant-swap-in-eagle-rock%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://fincastleherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffincastleherald.com%2Fplant-swap-in-eagle-rock%2F&#038;format=xml" />
		<style type="text/css">
		.feedzy-rss-link-icon:after {
			content: url( "https://fincastleherald.com/wp-content/plugins/feedzy-rss-feeds/img/external-link.png" );
			margin-left: 3px;
		}
	</style>
		<script>  var el_i13_login_captcha=null; var el_i13_register_captcha=null; </script><!-- SEO meta tags powered by SmartCrawl https://wpmudev.com/project/smartcrawl-wordpress-seo/ -->
<link rel="canonical" href="https://fincastleherald.com/plant-swap-in-eagle-rock/" />
<meta name="description" content="The Eagle Rock Library hosted a “Plant and Seed Swap” last weekend. By Matt de Simone &nbsp; The Eagle Rock Library recently held a &quot;Plant and Seed Swap.&quot; Visitors got to trade plants and seeds and learned more about gardening throughout the event. The library encouraged visitors to br ... | Fincastle Herald" />
<script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@type":"Organization","@id":"https:\/\/fincastleherald.com\/#schema-publishing-organization","url":"https:\/\/fincastleherald.com","name":"Fincastle Herald"},{"@type":"WebSite","@id":"https:\/\/fincastleherald.com\/#schema-website","url":"https:\/\/fincastleherald.com","name":"Mountain Media, LLC","encoding":"UTF-8","potentialAction":{"@type":"SearchAction","target":"https:\/\/fincastleherald.com\/search\/{search_term_string}\/","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https:\/\/fincastleherald.com\/plant-swap-in-eagle-rock\/#schema-webpage","isPartOf":{"@id":"https:\/\/fincastleherald.com\/#schema-website"},"publisher":{"@id":"https:\/\/fincastleherald.com\/#schema-publishing-organization"},"url":"https:\/\/fincastleherald.com\/plant-swap-in-eagle-rock\/"},{"@type":"Article","mainEntityOfPage":{"@id":"https:\/\/fincastleherald.com\/plant-swap-in-eagle-rock\/#schema-webpage"},"author":{"@type":"Person","@id":"https:\/\/fincastleherald.com\/author\/matt\/#schema-author","name":"Fincastle Herald","url":"https:\/\/fincastleherald.com\/author\/matt\/"},"publisher":{"@id":"https:\/\/fincastleherald.com\/#schema-publishing-organization"},"dateModified":"2022-04-26T12:06:59","datePublished":"2022-04-26T12:06:59","headline":"Plant swap in Eagle Rock","description":"The Eagle Rock Library hosted a \u201cPlant and Seed Swap\u201d last weekend. By Matt de Simone &nbsp; The Eagle Rock Library recently held a &quot;Plant and Seed Swap.&quot; Visitors got to trade plants and seeds and learned more about gardening throughout the event. The library encouraged visitors to br ... | Fincastle Herald","name":"Plant swap in Eagle Rock","image":{"@type":"ImageObject","@id":"https:\/\/fincastleherald.com\/plant-swap-in-eagle-rock\/#schema-article-image","url":"https:\/\/fincastleherald.com\/wp-content\/uploads\/sites\/16\/2022\/04\/DSC_0359-scaled.jpg","height":1696,"width":2560,"caption":"The Eagle Rock Library hosted a \u201cPlant and Seed Swap\u201d last weekend. "},"thumbnailUrl":"https:\/\/fincastleherald.com\/wp-content\/uploads\/sites\/16\/2022\/04\/DSC_0359-scaled.jpg"}]}</script>
<meta property="og:type" content="article" />
<meta property="og:url" content="https://fincastleherald.com/plant-swap-in-eagle-rock/" />
<meta property="og:title" content="Plant swap in Eagle Rock" />
<meta property="og:description" content="The Eagle Rock Library hosted a “Plant and Seed Swap” last weekend. By Matt de Simone &nbsp; The Eagle Rock Library recently held a &quot;Plant and Seed Swap.&quot; Visitors got to trade plants and seeds and learned more about gardening throughout the event. The library encouraged visitors to br ... | Fincastle Herald" />
<meta property="og:image" content="https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0359-scaled.jpg" />
<meta property="og:image:width" content="2560" />
<meta property="og:image:height" content="1696" />
<meta property="article:published_time" content="2022-04-26T12:06:59" />
<meta property="article:author" content="Fincastle Herald" />
<!-- /SEO -->
<!-- start Simple Custom CSS and JS -->
<style type="text/css">
.single-main .post-content-area</style>
<!-- end Simple Custom CSS and JS -->
<style type="text/css" id="branda-admin-bar-logo">
body #wpadminbar #wp-admin-bar-wp-logo > .ab-item {
	background-image: url(https://mountainmedianews.com/wp-content/uploads/2020/09/MM-Red-Logo.jpg);
	background-repeat: no-repeat;
	background-position: 50%;
	background-size: 80%;
}
body #wpadminbar #wp-admin-bar-wp-logo > .ab-item .ab-icon:before {
	content: " ";
}
</style>

<script type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
			<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	<script type="text/javascript">
			if ( 'undefined' == typeof advadsGATracking ) window.advadsGATracking = {};
		</script>
		<script  async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-4648783079594586" crossorigin="anonymous"></script><link rel="icon" href="https://fincastleherald.com/wp-content/uploads/sites/16/2021/03/Mountain-Virginia-Media-75x75.jpg" sizes="32x32" />
<link rel="icon" href="https://fincastleherald.com/wp-content/uploads/sites/16/2021/03/Mountain-Virginia-Media.jpg" sizes="192x192" />
<meta name="msapplication-TileImage" content="https://fincastleherald.com/wp-content/uploads/sites/16/2021/03/Mountain-Virginia-Media.jpg" />
<style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">@media only screen and (min-width : 1200px) { .container, .jeg_vc_content > .vc_row, .jeg_vc_content > .vc_element > .vc_row, .jeg_vc_content > .vc_row[data-vc-full-width="true"]:not([data-vc-stretch-content="true"]) > .jeg-vc-wrapper, .jeg_vc_content > .vc_element > .vc_row[data-vc-full-width="true"]:not([data-vc-stretch-content="true"]) > .jeg-vc-wrapper { max-width : 1220px; } .elementor-section.elementor-section-boxed > .elementor-container { max-width : 1220px; }  } @media only screen and (min-width : 1441px) { .container, .jeg_vc_content > .vc_row, .jeg_vc_content > .vc_element > .vc_row, .jeg_vc_content > .vc_row[data-vc-full-width="true"]:not([data-vc-stretch-content="true"]) > .jeg-vc-wrapper, .jeg_vc_content > .vc_element > .vc_row[data-vc-full-width="true"]:not([data-vc-stretch-content="true"]) > .jeg-vc-wrapper { max-width : 1343px; } .elementor-section.elementor-section-boxed > .elementor-container { max-width : 1343px; }  } .jeg_topbar .jeg_nav_row, .jeg_topbar .jeg_search_no_expand .jeg_search_input { line-height : 51px; } .jeg_topbar .jeg_nav_row, .jeg_topbar .jeg_nav_icon { height : 51px; } .jeg_midbar { height : 186px; } .jeg_header .jeg_button_1 .btn { background : #1e73be; } </style><style type="text/css">
					.no_thumbnail .jeg_thumb,
					.thumbnail-container.no_thumbnail {
					    display: none !important;
					}
					.jeg_search_result .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,
					.jeg_sidefeed .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,
					.jeg_pl_sm.no_thumbnail .jeg_postblock_content {
					    margin-left: 0;
					}
					.jeg_postblock_11 .no_thumbnail .jeg_postblock_content,
					.jeg_postblock_12 .no_thumbnail .jeg_postblock_content,
					.jeg_postblock_12.jeg_col_3o3 .no_thumbnail .jeg_postblock_content  {
					    margin-top: 0;
					}
					.jeg_postblock_15 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
					.jeg_postblock_19 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
					.jeg_postblock_24 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
					.jeg_sidefeed .jeg_pl_md_box .jeg_postblock_content {
					    position: relative;
					}
					.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a,
					.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a:hover,
					.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_meta .fa {
					    color: #212121 !important;
					} 
				</style><meta name="pwaforwp" content="wordpress-plugin"/>
        <meta name="theme-color" content="#D5E0EB">
        <meta name="apple-mobile-web-app-title" content="Fincastle Herald">
        <meta name="application-name" content="Fincastle Herald">
        <meta name="apple-mobile-web-app-capable" content="yes">
        <meta name="apple-mobile-web-app-status-bar-style" content="default">
        <meta name="mobile-web-app-capable" content="yes">
        <meta name="apple-touch-fullscreen" content="YES">
<link rel="apple-touch-startup-image" href="https://fincastleherald.com/wp-content/plugins/pwa-for-wp/images/logo.png">
<link rel="apple-touch-icon" sizes="192x192" href="https://fincastleherald.com/wp-content/plugins/pwa-for-wp/images/logo.png">
<link rel="apple-touch-icon" sizes="512x512" href="https://fincastleherald.com/wp-content/plugins/pwa-for-wp/images/logo-512x512.png">
</head>
<body class="post-template-default single single-post postid-79075 single-format-standard wp-embed-responsive theme-jnews woocommerce-no-js ehf-template-jnews ehf-stylesheet-jnews-child jeg_toggle_dark jeg_single_tpl_2 jnews jsc_normal elementor-default elementor-kit-55667 aa-prefix-finca-">

    
    
    <div class="jeg_ad jeg_ad_top jnews_header_top_ads">
        <div class='ads-wrapper  '></div>    </div>

    <!-- The Main Wrapper
    ============================================= -->
    <div class="jeg_viewport">

        
        <div class="jeg_header_wrapper">
            <div class="jeg_header_instagram_wrapper">
    </div>

<!-- HEADER -->
<div class="jeg_header normal">
    <div class="jeg_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item jeg_nav_html">
    <a href="https://mountainmedianews.com" target="_blank"><img class="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20125%2050'%3E%3C/svg%3E" data-src="https://s-haven.com/wp-content/uploads/2021/09/MM-VM-with-Owl.png" width="125" height="50" alt=""/></a></div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                                            </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_logo jeg_desktop_logo">
			<div class="site-title">
			<a href="https://fincastleherald.com/" style="padding: 0 0 0 0;">
				<img class='jeg_logo_img lazy' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201%201'%3E%3C/svg%3E" data-src="https://fincastleherald.com/wp-content/uploads/sites/16/2021/09/FH-masthead.jpg" data-srcset="https://fincastleherald.com/wp-content/uploads/sites/16/2021/09/FH-masthead.jpg 1x, https://fincastleherald.com/wp-content/uploads/sites/16/2021/09/FH-masthead.jpg 2x" alt="Fincastle Herald"data-light-src="https://fincastleherald.com/wp-content/uploads/sites/16/2021/09/FH-masthead.jpg" data-light-srcset="https://fincastleherald.com/wp-content/uploads/sites/16/2021/09/FH-masthead.jpg 1x, https://fincastleherald.com/wp-content/uploads/sites/16/2021/09/FH-masthead.jpg 2x" data-dark-src="https://fincastleherald.com/wp-content/uploads/sites/16/2017/04/FH-mastheadinverse.jpg" data-dark-srcset="https://fincastleherald.com/wp-content/uploads/sites/16/2017/04/FH-mastheadinverse.jpg 1x, https://fincastleherald.com/wp-content/uploads/sites/16/2017/04/FH-mastheadinverse.jpg 2x">			</a>
		</div>
	</div>
                    </div>
                </div>

                        </div>
    </div>
</div><div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item jeg_main_menu_wrapper">
<div class="jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li id="menu-item-36597" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-36597 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-29564" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-29564 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/fh-local-stories/">Local News</a></li>
	<li id="menu-item-29431" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29431 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/fh-featured-sports/">Featured Sports</a></li>
	<li id="menu-item-56013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-56013 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/courthouse-news/">Courthouse</a>
	<ul class="sub-menu">
		<li id="menu-item-43351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43351 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/legals/">Legals</a></li>
	</ul>
</li>
	<li id="menu-item-29567" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29567 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/fh-sports/">Sports News</a></li>
	<li id="menu-item-29566" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29566 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/fh-school/">School News</a></li>
	<li id="menu-item-29563" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29563 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/entertainment/">Entertainment News</a></li>
	<li id="menu-item-29561" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29561 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/fh-church/">Church</a></li>
</ul>
</li>
<li id="menu-item-54228" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54228 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/opinions/">Opinions</a></li>
<li id="menu-item-29565" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29565 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/fh-obituaries/">Obituaries</a></li>
<li id="menu-item-29562" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29562 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/eherald/">eHerald</a></li>
<li id="menu-item-74365" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-74365 bgnav" data-item-row="default" ><a href="https://mountainmedianews.com/mm/virginia-media-inc/">State News</a></li>
<li id="menu-item-74366" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-74366 bgnav" data-item-row="default" ><a href="https://mountainmedianews.com/mm/national/">National News</a></li>
<li id="menu-item-73563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-73563 bgnav" data-item-row="default" ><a href="https://mountainmedianews.com/classifieds/">Classifieds</a></li>
<li id="menu-item-74370" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-74370 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/contact/">Contact</a></li>
<li id="menu-item-74369" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-74369 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/my-account/">My Account</a></li>
<li id="menu-item-74760" class="lrm-login lrm-hide-if-logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-74760 bgnav" data-item-row="default" ><a href="#login">Login</a></li>
</ul></div></div>
                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                    <div class="item_wrap jeg_nav_aligncenter">
                                            </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <!-- Button -->
<div class="jeg_nav_item jeg_button_1">
    		<a href="https://fincastleherald.com/subscribe/"
		   class="btn default "
		   target="_self">
			<i class=""></i>
			Subscribe For $2.50/Month		</a>
		</div>                    </div>
                </div>

                        </div>
    </div>
</div></div><!-- /.jeg_header -->        </div>

        <div class="jeg_header_sticky">
            <div class="sticky_blankspace"></div>
<div class="jeg_header normal">
    <div class="jeg_container">
        <div data-mode="fixed" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal">
            <div class="container">
    <div class="jeg_nav_row">
        
            <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                <div class="item_wrap jeg_nav_alignleft">
                    <div class="jeg_nav_item jeg_main_menu_wrapper">
<div class="jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li id="menu-item-36597" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-36597 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-29564" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-29564 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/fh-local-stories/">Local News</a></li>
	<li id="menu-item-29431" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29431 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/fh-featured-sports/">Featured Sports</a></li>
	<li id="menu-item-56013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-56013 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/courthouse-news/">Courthouse</a>
	<ul class="sub-menu">
		<li id="menu-item-43351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43351 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/legals/">Legals</a></li>
	</ul>
</li>
	<li id="menu-item-29567" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29567 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/fh-sports/">Sports News</a></li>
	<li id="menu-item-29566" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29566 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/fh-school/">School News</a></li>
	<li id="menu-item-29563" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29563 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/entertainment/">Entertainment News</a></li>
	<li id="menu-item-29561" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29561 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/fh-church/">Church</a></li>
</ul>
</li>
<li id="menu-item-54228" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54228 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/opinions/">Opinions</a></li>
<li id="menu-item-29565" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29565 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/fh-obituaries/">Obituaries</a></li>
<li id="menu-item-29562" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29562 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/category/eherald/">eHerald</a></li>
<li id="menu-item-74365" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-74365 bgnav" data-item-row="default" ><a href="https://mountainmedianews.com/mm/virginia-media-inc/">State News</a></li>
<li id="menu-item-74366" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-74366 bgnav" data-item-row="default" ><a href="https://mountainmedianews.com/mm/national/">National News</a></li>
<li id="menu-item-73563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-73563 bgnav" data-item-row="default" ><a href="https://mountainmedianews.com/classifieds/">Classifieds</a></li>
<li id="menu-item-74370" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-74370 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/contact/">Contact</a></li>
<li id="menu-item-74369" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-74369 bgnav" data-item-row="default" ><a href="https://fincastleherald.com/my-account/">My Account</a></li>
<li id="menu-item-74760" class="lrm-login lrm-hide-if-logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-74760 bgnav" data-item-row="default" ><a href="#login">Login</a></li>
</ul></div></div>
                </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                <div class="item_wrap jeg_nav_aligncenter">
                                    </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                <div class="item_wrap jeg_nav_alignright">
                    <!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://fincastleherald.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                </div>
            </div>

                </div>
</div>        </div>
    </div>
</div>
        </div>

        <div class="jeg_navbar_mobile_wrapper">
            <div class="jeg_navbar_mobile" data-mode="scroll">
    <div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item">
    <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_mobile_logo">
			<div class="site-title">
	    	<a href="https://fincastleherald.com/">
		        <img class='jeg_logo_img lazy' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201%201'%3E%3C/svg%3E" data-src="https://fincastleherald.com/wp-content/uploads/sites/16/2017/01/FH-masthead-e1483714790112.jpg" data-srcset="https://fincastleherald.com/wp-content/uploads/sites/16/2017/01/FH-masthead-e1483714790112.jpg 1x, https://fincastleherald.com/wp-content/uploads/sites/16/2017/01/FH-masthead-e1483714790112.jpg 2x" alt="Fincastle Herald"data-light-src="https://fincastleherald.com/wp-content/uploads/sites/16/2017/01/FH-masthead-e1483714790112.jpg" data-light-srcset="https://fincastleherald.com/wp-content/uploads/sites/16/2017/01/FH-masthead-e1483714790112.jpg 1x, https://fincastleherald.com/wp-content/uploads/sites/16/2017/01/FH-masthead-e1483714790112.jpg 2x" data-dark-src="https://fincastleherald.com/wp-content/uploads/sites/16/2017/04/FH-mastheadinverse.jpg" data-dark-srcset="https://fincastleherald.com/wp-content/uploads/sites/16/2017/04/FH-mastheadinverse.jpg 1x, https://fincastleherald.com/wp-content/uploads/sites/16/2017/04/FH-mastheadinverse.jpg 2x">		    </a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
	<form action="https://fincastleherald.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                    </div>
                </div>

                        </div>
    </div>
</div>            <div class="jeg_navbar_mobile_menu">
                <div class="container">
                    <div class="menu-state-national-container"><ul id="menu-state-national" class="jeg_mobile_menu_style_1"><li id="menu-item-70352" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-70352"><a href="https://mountainmedianews.com/mm/national/">National News</a></li>
<li id="menu-item-70353" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-70353"><a href="https://mountainmedianews.com/mm/virginia-media-inc/">VA News</a></li>
<li id="menu-item-70354" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-70354"><a href="https://mountainmedianews.com/mm/west-virginia/">WV News</a></li>
</ul></div>                </div>
            </div>
        </div>
<div class="sticky_blankspace" style="height: 60px;"></div>        </div>

            <div class="post-wrapper">

        <div class="post-wrap" >

            
            <div class="jeg_main jeg_wide_content">
                <div class="jeg_container">
                    <div class="jeg_content jeg_singlepage">
	<div class="container">

		<div class="jeg_ad jeg_article_top jnews_article_top_ads">
			<div class='ads-wrapper  '></div>		</div>

		
						<div class="jeg_breadcrumbs jeg_breadcrumb_container">
				<div id="breadcrumbs"><span class="">
                <a href="https://fincastleherald.com">Home</a>
            </span><i class="fa fa-angle-right"></i><span class="breadcrumb_last_link">
                <a href="https://fincastleherald.com/category/featured-2/">Featured</a>
            </span></div>			</div>
			
			<div class="entry-header">
				
				<h1 class="jeg_post_title">Plant swap in Eagle Rock</h1>

				
				<div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_2">
    <div class="meta_left">
        
                    <div class="jeg_meta_date">
                <a href="https://fincastleherald.com/plant-swap-in-eagle-rock/">April 26, 2022</a>
            </div>
        
                    <div class="jeg_meta_category">
                <span><span class="meta_text">in</span>
                    <a href="https://fincastleherald.com/category/featured-2/" rel="category tag">Featured</a><span class="category-separator">, </span><a href="https://fincastleherald.com/category/fh-local-stories/" rel="category tag">Local News</a>                </span>
            </div>
        
        <div class="jeg_meta_reading_time">
			            <span>
			            	Reading Time: 2 mins read
			            </span>
			        </div>    </div>

	<div class="meta_right">
		<div class="jeg_meta_zoom" data-in-step="3" data-out-step="2">
							<div class="zoom-dropdown">
								<div class="zoom-icon">
									<span class="zoom-icon-small">A</span>
									<span class="zoom-icon-big">A</span>
								</div>
								<div class="zoom-item-wrapper">
									<div class="zoom-item">
										<button class="zoom-out"><span>A</span></button>
										<button class="zoom-in"><span>A</span></button>
										<div class="zoom-bar-container">
											<div class="zoom-bar"></div>
										</div>
										<button class="zoom-reset"><span>Reset</span></button>
									</div>
								</div>
							</div>
						</div>			</div>
</div>
</div>
			</div>

			<div class="row">
				<div class="jeg_main_content col-md-9">

					<div class="jeg_inner_content">
						
						<div class="jeg_share_top_container"><div class="jeg_share_button clearfix">
                <div class="jeg_share_stats">
                    
                    <div class="jeg_views_count">
                    <div class="counts">2</div>
                    <span class="sharetext">VIEWS</span>
                </div>
                </div>
                <div class="jeg_sharelist">
                    <a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Ffincastleherald.com%2Fplant-swap-in-eagle-rock%2F" rel='nofollow'  class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share on Facebook</span></a><a href="https://twitter.com/intent/tweet?text=Plant%20swap%20in%20Eagle%20Rock&url=https%3A%2F%2Ffincastleherald.com%2Fplant-swap-in-eagle-rock%2F" rel='nofollow'  class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Share on Twitter</span></a><a href="https://www.pinterest.com/pin/create/bookmarklet/?pinFave=1&url=https%3A%2F%2Ffincastleherald.com%2Fplant-swap-in-eagle-rock%2F&media=https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0359-scaled.jpg&description=Plant%20swap%20in%20Eagle%20Rock" rel='nofollow'  class="jeg_btn-pinterest "><i class="fa fa-pinterest"></i></a>
                    <div class="share-secondary">
                    <a href="https://plus.google.com/share?url=https%3A%2F%2Ffincastleherald.com%2Fplant-swap-in-eagle-rock%2F" rel='nofollow'  class="jeg_btn-google-plus removed "><i class="fa fa-google-plus"></i></a><a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Ffincastleherald.com%2Fplant-swap-in-eagle-rock%2F&title=Plant%20swap%20in%20Eagle%20Rock" rel='nofollow'  class="jeg_btn-linkedin "><i class="fa fa-linkedin"></i></a>
                </div>
                <a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a>
                </div>
            </div></div>
						<div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper  '></div></div>
						<div class="entry-content no-share">
							<div class="jeg_share_button share-float jeg_sticky_share clearfix share-monocrhome">
								<div class="jeg_share_float_container"></div>							</div>

							<div class="content-inner ">
								<figure id="attachment_78966" aria-describedby="caption-attachment-78966" style="width: 300px" class="wp-caption alignright"><img class="size-medium wp-image-78966 lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20199'%3E%3C/svg%3E" data-src="https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0359-300x199.jpg" alt="" width="300" height="199" data-srcset="https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0359-300x199.jpg 300w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0359-1024x678.jpg 1024w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0359-768x509.jpg 768w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0359-1536x1017.jpg 1536w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0359-2048x1356.jpg 2048w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0359-600x397.jpg 600w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0359-750x497.jpg 750w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0359-1140x755.jpg 1140w" data-sizes="(max-width: 300px) 100vw, 300px" /><figcaption id="caption-attachment-78966" class="wp-caption-text">The Eagle Rock Library hosted a “Plant and Seed Swap” last weekend.</figcaption></figure>
<p><em>By Matt de Simone</em></p>
<p>&nbsp;</p>
<p>The Eagle Rock Library recently held a &#8220;Plant and Seed Swap.&#8221; Visitors got to trade plants and seeds and learned more about gardening throughout the event. The library encouraged visitors to bring plants, cuttings, or seeds they would be willing to share and swap with other attendees.</p>
<p>&#8220;This is the first time we presented a &#8216;plant swap,'&#8221; Eagle Rock Branch Manager Jaime Duval said when asked about the event. &#8220;Pre-COVID, our Friends of the Library volunteer group held a plant sale that went really well. Our programming team thought a garden event with a plant swap might appeal to our community.”</p>
<figure id="attachment_78968" aria-describedby="caption-attachment-78968" style="width: 300px" class="wp-caption alignleft"><img loading="lazy" class="size-medium wp-image-78968 lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20199'%3E%3C/svg%3E" data-src="https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0363-300x199.jpg" alt="" width="300" height="199" data-srcset="https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0363-300x199.jpg 300w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0363-1024x678.jpg 1024w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0363-768x509.jpg 768w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0363-1536x1017.jpg 1536w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0363-2048x1356.jpg 2048w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0363-600x397.jpg 600w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0363-750x497.jpg 750w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0363-1140x755.jpg 1140w" data-sizes="(max-width: 300px) 100vw, 300px" /><figcaption id="caption-attachment-78968" class="wp-caption-text">Abby Pierson (center) of Mountain Castles Soil &amp; Water observes Silas Whitson (right) as he drills a hole in a water barrel.</figcaption></figure>
<p>The plant and seed swap was the first event presented by the Eagle Rock Library since the start of the pandemic. Visitors enjoyed the sunshine and were excited to begin their spring gardening season by learning about healthy gardening.</p>
<p>The Botetourt 4-H Honey Club provided information on bees, pollination, and uses of honey. Bruce Ingram, a local author of young adult novels, brought a few selections for visitors to purchase. The Salem Library&#8217;s Teresa Baga brought the Spring 2022 Flower Seed catalog, assorted seeds, and adaptive gardening tools. Participants were allowed to take seeds home to plant. Then, once their fully grown plants produce seeds, they can return those seeds for other people to use.</p>
<p><figure id="attachment_78971" aria-describedby="caption-attachment-78971" style="width: 300px" class="wp-caption alignleft"><img loading="lazy" class="size-medium wp-image-78971 lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20199'%3E%3C/svg%3E" data-src="https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0368-300x199.jpg" alt="" width="300" height="199" data-srcset="https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0368-300x199.jpg 300w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0368-1024x678.jpg 1024w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0368-768x509.jpg 768w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0368-1536x1017.jpg 1536w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0368-2048x1356.jpg 2048w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0368-600x397.jpg 600w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0368-750x497.jpg 750w, https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0368-1140x755.jpg 1140w" data-sizes="(max-width: 300px) 100vw, 300px" /><figcaption id="caption-attachment-78971" class="wp-caption-text">Teresa Baga of the Salem Library shows a visitor information about the seed library. [PHOTOS: Matt de Simone]</figcaption></figure>Mountain Castles Soil &amp; Water&#8217;s Abby Pierson presented a water barrel workshop for attendees. These rain barrels collect water better to mitigate erosion and harvest water for gardens or livestock. Mountain Castles partnered with Clean Valley Council, which connected Mountain Castles with Coca-Cola, which provided the barrels. Participants brought their materials, like faucets and spigots, to build their barrels.</p>
<p>&#8220;I&#8217;m hoping we can expand (this event) in future years,&#8221; Duval added.</p>
<p>To learn more about upcoming events at Botetourt County Libraries, visit <a href="https://www.botetourtva.gov/Calendar.aspx">https://www.botetourtva.gov/Calendar.aspx</a>.</p>
<div class="finca-3f930c06df71e2279604e6ab3d6ac710" id="finca-3f930c06df71e2279604e6ab3d6ac710"></div><div class="finca-e5d37a9fb787bfe63f58ff8358ccc595" id="finca-e5d37a9fb787bfe63f58ff8358ccc595"></div>								
								
															</div>


						</div>
						<div class="jeg_share_bottom_container"><div class="jeg_share_button share-bottom clearfix">
                <div class="jeg_sharelist">
                    <a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Ffincastleherald.com%2Fplant-swap-in-eagle-rock%2F" rel='nofollow' class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share</span></a><a href="https://twitter.com/intent/tweet?text=Plant%20swap%20in%20Eagle%20Rock&url=https%3A%2F%2Ffincastleherald.com%2Fplant-swap-in-eagle-rock%2F" rel='nofollow' class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Tweet</span></a><a href="https://www.pinterest.com/pin/create/bookmarklet/?pinFave=1&url=https%3A%2F%2Ffincastleherald.com%2Fplant-swap-in-eagle-rock%2F&media=https://fincastleherald.com/wp-content/uploads/sites/16/2022/04/DSC_0359-scaled.jpg&description=Plant%20swap%20in%20Eagle%20Rock" rel='nofollow' class="jeg_btn-pinterest expanded"><i class="fa fa-pinterest"></i><span>Pin</span></a>
                    <div class="share-secondary">
                    <a href="https://plus.google.com/share?url=https%3A%2F%2Ffincastleherald.com%2Fplant-swap-in-eagle-rock%2F" rel='nofollow'  class="jeg_btn-google-plus removed "><i class="fa fa-google-plus"></i></a><a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Ffincastleherald.com%2Fplant-swap-in-eagle-rock%2F&title=Plant%20swap%20in%20Eagle%20Rock" rel='nofollow'  class="jeg_btn-linkedin "><i class="fa fa-linkedin"></i></a>
                </div>
                <a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a>
                </div>
            </div></div>
												<div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper  '></div></div><div class="jnews_prev_next_container"><div class="jeg_prevnext_post">
            <a href="https://fincastleherald.com/sheriffs-office-unveils-new-black-and-white-patrol-vehicle/" class="post prev-post">
            <span class="caption">Previous Post</span>
            <h3 class="post-title">Sheriff’s Office unveils new black and white patrol vehicle</h3>
        </a>
    
            <a href="https://fincastleherald.com/btec-grad-establishes-pure-elegance-in-troutville/" class="post next-post">
            <span class="caption">Next Post</span>
            <h3 class="post-title">BTEC grad establishes ‘Pure Elegance’ in Troutville</h3>
        </a>
    </div></div><div class="jnews_author_box_container "></div><div class="jnews_related_post_container"></div><div class="jnews_popup_post_container"></div><div class="jnews_comment_container">	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/plant-swap-in-eagle-rock/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://fincastleherald.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required" aria-hidden="true">*</span></label> <textarea autocomplete="new-password"  id="b98ad4247e"  name="b98ad4247e"   cols="45" rows="8" maxlength="65525" required="required"></textarea><textarea id="comment" aria-label="hp-comment" aria-hidden="true" name="comment" autocomplete="new-password" style="padding:0 !important;clip:rect(1px, 1px, 1px, 1px) !important;position:absolute !important;white-space:nowrap !important;height:1px !important;width:1px !important;overflow:hidden !important;" tabindex="-1"></textarea><script data-noptimize type="text/javascript">document.getElementById("comment").setAttribute( "id", "ac18dbde7c0db263b83b7d41e263766c" );document.getElementById("b98ad4247e").setAttribute( "id", "comment" );</script></p><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required" /></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='79075' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	</div>					</div>

				</div>
				
<div class="jeg_sidebar  jeg_sticky_sidebar col-md-3">
    <div class="jegStickyHolder"><div class="theiaStickySidebar"><div class="widget finca-widget"><div style="margin-left: auto; margin-right: auto; text-align: center; " id="finca-1864136054"><a data-bid="16" href="https://fincastleherald.com/linkout/77100" target="_blank"><img src="https://fincastleherald.com/wp-content/uploads/sites/16/2022/01/DigitalAd_FincastleHerald_350x350_Female1.jpg" alt=""  class="no-lazyload" width="350" height="350"  style="display: inline-block;" /></a></div></div><div class="widget finca-widget"><div class="finca-c673bd4dfb31b12c0b0f486f61593c56" id="finca-c673bd4dfb31b12c0b0f486f61593c56"></div></div><div class="widget finca-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-4648783079594586",
          enable_page_level_ads: true
     });
</script></div><div class="widget finca-widget"><div class="finca-62cb9bbd0b6f8f4ec7fbdace6d0e6599" id="finca-62cb9bbd0b6f8f4ec7fbdace6d0e6599"></div></div><div class="widget  jeg_pb_boxed widget_mailster_signup" id="mailster_signup-2"><div class="jeg_block_heading jeg_block_heading_4 jnews_626836c00135e"><h3 class="jeg_block_title"><span>Sign Up To Our Newsletter</span></h3></div><style scoped>.jnews_626836c00135e.jeg_block_heading_4 .jeg_block_title span { background: #158096; }</style><div class="mailster-widget mailster-widget-signup"><div class="mailster-widget-text mailster-widget-text-before">Sign up now to get weekly top stories, eEdition notifications, deals and more from Fincastle Herald right to your inbox.</div><style id='mailster-form-default' type='text/css'>.mailster-embeded-form body{background:0;padding:0;margin:0}.mailster-embeded-form .mailster-form-body{padding:5px !important;margin:auto !important}.mailster-form-wrap{max-width:100%;max-height:95%;min-width:100px;-webkit-overflow-scrolling:touch}.mailster-form{margin-bottom:20px;position:relative}.mailster-form:before{content:'';position:absolute;display:block;height:100%;width:100%;z-index:1;background-repeat:no-repeat;background-position:center center;background-size:20px 20px;background-image:url('https://fincastleherald.com/wp-content/plugins/mailster/assets/css/../img/loading.gif');visibility:hidden;opacity:0;transition:opacity .15s ease-in-out}.mailster-form.loading:before{opacity:1;visibility:visible}@media only screen and (-webkit-min-device-pixel-ratio:2),only screen and (min-resolution:192dpi){.mailster-form:before{background-image:url('https://fincastleherald.com/wp-content/plugins/mailster/assets/css/../img/loading_2x.gif')}}.mailster-form:after,.mailster-form-fields:after{content:'.';visibility:hidden;display:block;height:0;clear:both}.mailster-form,.mailster-form .input,.mailster-form .mailster-form-info{width:100%;box-sizing:border-box}.mailster-embeded-form .mailster-form{margin-bottom:3px}.mailster-form .mailster-wrapper{position:relative;margin-bottom:2px;transition:opacity .15s ease-in-out}.mailster-form.loading .mailster-wrapper{opacity:.2}.mailster-form textarea.input{resize:vertical;height:150px}.mailster-form li{list-style:none !important;margin-left:0;padding-left:0}span.mailster-required{font-size:120%;font-weight:700;color:#bf4d4d}.mailster-lists-wrapper ul{list-style:none;margin-left:0;padding-left:0}.mailster-lists-wrapper ul li{margin-left:0}.mailster-list-description{color:inherit;display:block;margin-left:25px;font-size:.8em}.mailster-form-info{height:0;border-radius:2px;padding:5px;margin-bottom:4px;color:#fff;padding:9px 16px;transition:all .2s;-webkit-transform:scale(0);-moz-transform:scale(0);-ms-transform:scale(0);transform:scale(0)}.mailster-form.loading .mailster-form-info{opacity:0}.mailster-form-info a{color:#fff}.mailster-form-info.success,.mailster-form-info.error{display:block;height:100%;-webkit-transform:scale(1);-moz-transform:scale(1);-ms-transform:scale(1);transform:scale(1)}.mailster-form .error input,.mailster-form .error select,.mailster-form .error textarea{outline:2px solid #bf4d4d;outline-offset:0}.mailster-form-info.error{background:#bf4d4d}.mailster-form-info.success{background-color:#6fbf4d;text-align:center}.mailster-form-info ul,.mailster-form .mailster-form-info p{margin:0;padding:0;max-width:initial}.mailster-form-info ul li{color:inherit;margin-left:0}.mailster-submit-wrapper{margin-top:6px}.mailster-form .submit-button{cursor:pointer}.mailster-form .submit-button:focus{outline:0}</style><form action="https://fincastleherald.com/mailster/subscribe" method="post" class="mailster-form mailster-form-submit mailster-ajax-form mailster-in-widget mailster-form-1" novalidate><input name="_action" type="hidden" value="subscribe">
<input name="_timestamp" type="hidden" value="1650996928">
<input name="_referer" type="hidden" value="https://fincastleherald.com/plant-swap-in-eagle-rock/">
<input name="_nonce" type="hidden" value="c2447acf54">
<input name="formid" type="hidden" value="1">
<div class="mailster-form-fields">
<div class="mailster-wrapper mailster-email-wrapper"><label for="mailster-email-1">Email <span class="mailster-required">*</span></label><input id="mailster-email-1" name="email" type="email" value="" class="input mailster-email mailster-required" aria-required="true" aria-label="Email" spellcheck="false"></div>
<div class="mailster-wrapper mailster-firstname-wrapper"><label for="mailster-firstname-1">First Name</label><input id="mailster-firstname-1" name="firstname" type="text" value="" class="input mailster-firstname" aria-required="false" aria-label="First Name"></div>
<div class="mailster-wrapper mailster-lastname-wrapper"><label for="mailster-lastname-1">Last Name</label><input id="mailster-lastname-1" name="lastname" type="text" value="" class="input mailster-lastname" aria-required="false" aria-label="Last Name"></div>
<div class="mailster-wrapper mailster-lists-wrapper"><label>Lists</label><ul class="mailster-list"><li><label title=""><input type="hidden" name="lists[0]" value=""><input class="mailster-list mailster-list-eedition" type="checkbox" name="lists[0]" value="2"  checked='checked' aria-label="eEdition Notification"> eEdition Notification</label></li><li><label title=""><input type="hidden" name="lists[1]" value=""><input class="mailster-list mailster-list-newsletter" type="checkbox" name="lists[1]" value="3"  checked='checked' aria-label="Newsletter"> Newsletter</label></li></ul></div>
<div class="mailster-wrapper mailster-submit-wrapper form-submit"><input name="submit" type="submit" value="Subscribe" class="submit-button button" aria-label="Subscribe"></div>
</div>
</form>
</div></div></div></div></div>			</div>

		
		<div class="jeg_ad jeg_article jnews_article_bottom_ads">
			<div class='ads-wrapper  '></div>		</div>

	</div>

</div>
                </div>
            </div>

            <div id="post-body-class" class="post-template-default single single-post postid-79075 single-format-standard wp-embed-responsive theme-jnews woocommerce-no-js ehf-template-jnews ehf-stylesheet-jnews-child jeg_toggle_dark jeg_single_tpl_2 jnews jsc_normal elementor-default elementor-kit-55667 aa-prefix-finca-"></div>

            
        </div>

        <div class="post-ajax-overlay">
    <div class="preloader_type preloader_dot">
        <div class="newsfeed_preloader jeg_preloader dot">
            <span></span><span></span><span></span>
        </div>
        <div class="newsfeed_preloader jeg_preloader circle">
            <div class="jnews_preloader_circle_outer">
                <div class="jnews_preloader_circle_inner"></div>
            </div>
        </div>
        <div class="newsfeed_preloader jeg_preloader square">
            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
        </div>
    </div>
</div>
    </div>
        <div class="footer-holder" id="footer" data-id="footer">
            <div class="jeg_footer jeg_footer_1 dark">
    <div class="jeg_footer_container jeg_container">
        <div class="jeg_footer_content">
            <div class="container">

                <div class="row">
                    <div class="jeg_footer_primary clearfix">
                        <div class="col-md-4 footer_column">
                                                    </div>
                        <div class="col-md-4 footer_column">
                                                    </div>
                        <div class="col-md-4 footer_column">
                                                    </div>
                    </div>
                </div>


                
                <div class="jeg_footer_secondary clearfix">

                    <!-- secondary footer right -->

                    <div class="footer_right">

                        <ul class="jeg_menu_footer"><li id="menu-item-69842" class="lrm-login lrm-hide-if-logged-in menu-item menu-item-type-custom menu-item-object-custom menu-item-69842"><a href="#login">Login</a></li>
<li id="menu-item-50022" class="xoo-el-myaccount-menu menu-item menu-item-type-custom menu-item-object-custom menu-item-50022"><a href="https://fincastleherald.com/my-account/">My Account</a></li>
<li id="menu-item-29426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29426"><a href="https://fincastleherald.com/subscribe/">Subscribe To Fincastle Herald</a></li>
<li id="menu-item-30476" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30476"><a href="https://fincastleherald.com/contact/">Contact Us</a></li>
<li id="menu-item-43517" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43517"><a href="https://fincastleherald.com/submit-content/">Submit Content</a></li>
</ul>
                        
                        
                    </div>

                    <!-- secondary footer left -->

                    
                    
                                            <p class="copyright"> © 2020 Mountain Media, LLC </p>
                    
                </div> <!-- secondary menu -->

                

            </div>
        </div>
    </div>
</div><!-- /.footer -->
        </div>

        <div class="jscroll-to-top">
        	<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a>
        </div>
    </div>

    <!-- Mobile Navigation
    ============================================= -->
<div id="jeg_off_canvas" class="normal">
    <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a>
    <div class="jeg_bg_overlay"></div>
    <div class="jeg_mobile_wrapper">
        <div class="nav_wrap">
    <div class="item_main">
        <div class="jeg_aside_item jeg_mobile_profile">
    <div class="jeg_mobile_profile_wrapper">
        <ul class="jeg_accountlink">
                    <li><a href="#jeg_loginform" class="jeg_popuplink"><i class="fa fa-lock"></i> Login</a></li>
                    <li><a href="#jeg_registerform" class="jeg_popuplink"><i class="fa fa-user"></i> Sign Up</a></li>
                    <li class="cart"><a href="https://fincastleherald.com/cart/"><i class="fa fa-shopping-cart"></i> Cart</a></li>
                </ul>	</div>
</div><!-- Search Form -->
<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://fincastleherald.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div><div class="jeg_aside_item">
    <ul class="jeg_mobile_menu"><li id="menu-item-74415" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-74415"><a href="https://fincastleherald.com/category/fh-local-stories/">Local News</a></li>
<li id="menu-item-74416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-74416"><a href="https://fincastleherald.com/category/fh-sports/">Sports News</a></li>
<li id="menu-item-74417" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-74417"><a href="https://fincastleherald.com/category/fh-obituaries/">Obituaries</a></li>
<li id="menu-item-74418" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-74418"><a href="https://fincastleherald.com/category/fh-school/">School News</a></li>
<li id="menu-item-74419" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-74419"><a href="https://fincastleherald.com/category/fh-church/">Church</a></li>
<li id="menu-item-74423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-74423"><a href="https://fincastleherald.com/category/notices/">Notices</a></li>
<li id="menu-item-74420" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-74420"><a href="https://fincastleherald.com/category/eherald/">eHerald</a></li>
<li id="menu-item-74421" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-74421"><a href="https://fincastleherald.com/my-account/">My Account</a></li>
<li id="menu-item-74422" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-74422"><a href="https://fincastleherald.com/subscribe/">Subscribe</a></li>
</ul></div>    </div>
    <div class="item_bottom">
        <div class="jeg_aside_item socials_widget nobg">
    <a href="http://facebook.com" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="http://twitter.com" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright">
	<p>© 2020 Mountain Media, LLC</p>
</div>    </div>
</div>    </div>
</div><!-- Login Popup Content -->
<div id="jeg_loginform" class="jeg_popup mfp-with-anim mfp-hide">
    <div class="jeg_popupform jeg_popup_account">
        <form action="#" data-type="login" method="post" accept-charset="utf-8">
            <h3>Welcome Back!</h3>            <p>Login to your account below</p>

            <!-- Form Messages -->
            <div class="form-message"></div>
            <p class="input_field">
                <input type="text" name="username" placeholder="Username" value="">
            </p>
            <p class="input_field">
                <input type="password" name="password" placeholder="Password" value="">
            </p>
            <p class="input_field remember_me">
                <input type="checkbox" id="remember_me" name="remember_me" value="true">
                <label for="remember_me">Remember Me</label>
            </p>
			<div class="g-recaptcha" data-sitekey=""></div>
			<p class="submit">
                <input type="hidden" name="action" value="login_handler">
                <input type="hidden" name="jnews_nonce" value="1808cbcbbf">
                <input type="submit" name="jeg_login_button" class="button" value="Log In" data-process="Processing . . ." data-string="Log In">
            </p>
            <div class="bottom_links clearfix">
                <a href="#jeg_forgotform" class="jeg_popuplink forgot">Forgotten Password?</a>
                                <a href="#jeg_registerform" class="jeg_popuplink"><i class="fa fa-user"></i> Sign Up</a>
                            </div>
        </form>
    </div>
</div>

<!-- Register Popup Content -->
<div id="jeg_registerform" class="jeg_popup mfp-with-anim mfp-hide">
    <div class="jeg_popupform jeg_popup_account">
        <form action="#" data-type="register" method="post" accept-charset="utf-8">
            <h3>Create New Account!</h3>            <p>Fill the forms below to register</p>

            <!-- Form Messages -->
            <div class="form-message"></div>

            <p class="input_field">
                <input type="text" name="email" placeholder="Your email" value="">
            </p>
            <p class="input_field">
                <input type="text" name="username" placeholder="Username" value="">
            </p>
			<div class="g-recaptcha" data-sitekey=""></div>
            <p class="submit">
                <input type="hidden" name="action" value="register_handler">
                <input type="hidden" name="jnews_nonce" value="1808cbcbbf">
                <input type="submit" name="jeg_login_button" class="button" value="Sign Up" data-process="Processing . . ." data-string="Sign Up">
            </p>
                        <div class="bottom_links clearfix">
                <span>All fields are required.</span>
                <a href="#jeg_loginform" class="jeg_popuplink"><i class="fa fa-lock"></i> Log In</a>
            </div>
        </form>
    </div>
</div>

<!-- Forgot Password Popup Content -->
<div id="jeg_forgotform" class="jeg_popup mfp-with-anim mfp-hide">
    <div class="jeg_popupform jeg_popup_account">
        <form action="#" data-type="forgot" method="post" accept-charset="utf-8">
            <h3>Retrieve your password</h3>
            <p>Please enter your username or email address to reset your password.</p>

            <!-- Form Messages -->
            <div class="form-message"></div>

            <p class="input_field">
                <input type="text" name="user_login" placeholder="Your email or username" value="">
            </p>
			<div class="g-recaptcha" data-sitekey=""></div>
            <p class="submit">
                <input type="hidden" name="action" value="forget_password_handler">
                <input type="hidden" name="jnews_nonce" value="1808cbcbbf">
                <input type="submit" name="jeg_login_button" class="button" value="Reset Password" data-process="Processing . . ." data-string="Reset Password">
            </p>
            <div class="bottom_links clearfix">
                <a href="#jeg_loginform" class="jeg_popuplink"><i class="fa fa-lock"></i> Log In</a>
            </div>
        </form>
    </div>
</div>
<style>/* LRM */
body.logged-in .lrm-hide-if-logged-in { display: none !important; }
body.logged-in [class*='lrm-hide-if-logged-in'] { display: none !important; }
body:not(.logged-in) .lrm-show-if-logged-in { display: none !important; }
body:not(.logged-in) [class*='lrm-show-if-logged-in'] { display: none !important; }
</style>
<!--
-->
<div class="lrm-main lrm-font-svg lrm-user-modal lrm-btn-style--default" style="visibility: hidden;"> <!-- this is the entire modal form, including the background -->
<!--<div class="lrm-user-modal" style="visibility: hidden;">  this is the entire modal form, including the background -->

    <div class="lrm-user-modal-container"> <!-- this is the container wrapper -->
        <div class="lrm-user-modal-container-inner"> <!-- this is the container wrapper -->

            <div class="lrm-signin-section "> <!-- log in form -->
	<form class="lrm-form js-lrm-form" action="#0" data-action="login">
        <div class="lrm-fieldset-wrap">

            <div class="lrm-integrations lrm-integrations--login">
                            </div>

            <p class="lrm-form-message lrm-form-message--init"></p>

            <div class="fieldset">
                                <label class="image-replace lrm-email lrm-ficon-mail" title="Email or Username"></label>
                <input name="username" class="full-width has-padding has-border" type="text" aria-label="Email or Username" placeholder="Email or Username" required value="" autocomplete="username" data-autofocus="1">
                <span class="lrm-error-message"></span>
            </div>

            <div class="fieldset">
                                <label class="image-replace lrm-password lrm-ficon-key" title="Password"></label>
                <input name="password" class="full-width has-padding has-border" type="password" aria-label="Password" placeholder="Password" required value="">
                <span class="lrm-error-message"></span>
                                    <span class="hide-password lrm-ficon-eye" data-show="Show" data-hide="Hide" aria-label="Show"></span>
                            </div>

            <div class="fieldset">
                                    <label class="lrm-nice-checkbox__label lrm-remember-me-checkbox">Remember me                        <input type="checkbox" class="lrm-nice-checkbox lrm-remember-me" name="remember-me" checked>
                        <div class="lrm-nice-checkbox__indicator"></div>
                    </label>
                            </div>

            <div class="lrm-integrations lrm-integrations--login lrm-integrations-before-btn">
                                            </div>

            <div class="lrm-integrations-otp"></div>

        </div>

		<div class="fieldset fieldset--submit fieldset--default">
			<button class="full-width has-padding" type="submit">
				Log in			</button>
		</div>

        <div class="lrm-fieldset-wrap">
            <div class="lrm-integrations lrm-integrations--login">
                            </div>
        </div>

		<input type="hidden" name="redirect_to" value="">
		<input type="hidden" name="lrm_action" value="login">
		<input type="hidden" name="wp-submit" value="1">
		<!-- Fix for Eduma WP theme-->
		<input type="hidden" name="lp-ajax" value="login">

		<input type="hidden" id="security-login" name="security-login" value="44379f5580" /><input type="hidden" name="_wp_http_referer" value="/plant-swap-in-eagle-rock/" />
		<!-- For Invisible Recaptcha plugin -->
		<span class="wpcf7-submit" style="display: none;"></span>
	</form>

	<p class="lrm-form-bottom-message"><a href="#0" class="lrm-switch-to--reset-password">Forgot your password?</a></p>
	<!-- <a href="#0" class="lrm-close-form">Close</a> -->
</div> <!-- lrm-login -->
	<div class="lrm-signup-section "> <!-- sign up form -->
		
			<form class="lrm-form js-lrm-form" action="#0" data-action="registration" data-lpignore="true">

                <div class="lrm-fieldset-wrap lrm-form-message-wrap">
                    <p class="lrm-form-message lrm-form-message--init"></p>
                </div>

                <div class="lrm-fieldset-wrap">

                    <div class="lrm-integrations lrm-integrations--register">
                                            </div>

                                                                        <div class="fieldset fieldset--username">
                                                                <label class="image-replace lrm-username lrm-ficon-user" for="signup-username" title="Username*"></label>
                                <input name="username" class="full-width has-padding has-border" id="signup-username" type="text" placeholder="Username*" required aria-label="Username*" autocomplete="off" data-lpignore="true">
                                <span class="lrm-error-message"></span>
                            </div>
                        
			                                        <div class="fieldset fieldset--login">
                                <label class="image-replace lrm-username lrm-ficon-user" for="signup-login" title="Login"></label>
                                <input name="login" class="full-width has-padding has-border" id="signup-login" type="text" autocomplete="off" data-lpignore="true">
                            </div>
	                    
                                                    <div class="clearfix lrm-row">
                                                                                                <div class="lrm-col-half-width lrm-col-first fieldset--first-name lrm-col">
                                    <label class="image-replace lrm-username lrm-ficon-user" for="signup-first-name" title="First name*"></label>
                                    <input name="first-name" class="full-width has-padding has-border" id="signup-first-name" type="text" placeholder="First name*" required aria-label="First name*" autocomplete="off" data-lpignore="true">
                                    <span class="lrm-error-message"></span>
                                </div>
                                <div class="lrm-col-half-width lrm-col-last fieldset--last-name lrm-col">
                                    <label class="image-replace lrm-username lrm-ficon-user" for="signup-last-name" title="Last name"></label>
                                    <input name="last-name" class="full-width has-padding has-border" id="signup-last-name" type="text" placeholder="Last name" aria-label="Last name" autocomplete="off" data-lpignore="true">
                                    <span class="lrm-error-message"></span>
                                </div>
                            </div>
                        
                        <div class="fieldset fieldset--email">
                                                        <label class="image-replace lrm-email lrm-ficon-mail" for="signup-email" title="Email*"></label>
                            <input name="email" class="full-width has-padding has-border" id="signup-email" type="email" placeholder="Email*" required autocomplete="off" aria-label="Email*">
                            <span class="lrm-error-message"></span>
                        </div>

	                    	                    	                    
	                    
	                    
                        <div class="lrm-integrations lrm-integrations--register">
		                    		                                            </div>

	                    
                    
                    <div class="lrm-integrations lrm-integrations--register lrm-info lrm-info--register">
                                            </div>

				</div>

				<div class="fieldset fieldset--submit fieldset--default">
					<button class="full-width has-padding" type="submit">
						Create account					</button>
				</div>

                <div class="lrm-fieldset-wrap">

                    <div class="lrm-integrations lrm-integrations--register">
                                            </div>

                </div>

				<input type="hidden" name="redirect_to" value="">
				<input type="hidden" name="lrm_action" value="signup">
				<input type="hidden" name="wp-submit" value="1">

				<!-- Fix for Eduma WP theme-->
				<input type="hidden" name="is_popup_register" value="1">
				<input type="hidden" id="security-signup" name="security-signup" value="0030e15714" /><input type="hidden" name="_wp_http_referer" value="/plant-swap-in-eagle-rock/" />				<!-- For Invisible Recaptcha plugin -->
				<span class="wpcf7-submit" style="display: none;"></span>

			</form>

		
		<!-- <a href="#0" class="lrm-close-form">Close</a> -->
	</div> <!-- lrm-signup -->

<div class="lrm-reset-password-section "> <!-- reset password form -->
	<form class="lrm-form js-lrm-form" action="#0" data-action="lost-password">

        <div class="lrm-fieldset-wrap">
            <p class="lrm-form-message">Lost your password? Please enter your email address. You will receive mail with link to set new password.</p>

            <div class="fieldset">
                                <label class="image-replace lrm-email lrm-ficon-mail" title="Email or Username"></label>
                <input class="full-width has-padding has-border" name="user_login" type="text" required placeholder="Email or Username" data-autofocus="1" aria-label="Email or Username">
                <span class="lrm-error-message"></span>
            </div>

            <div class="lrm-integrations lrm-integrations--reset-pass">
                            </div>

            <input type="hidden" name="lrm_action" value="lostpassword">
            <input type="hidden" name="wp-submit" value="1">
            <input type="hidden" id="security-lostpassword" name="security-lostpassword" value="34bc1bdbec" /><input type="hidden" name="_wp_http_referer" value="/plant-swap-in-eagle-rock/" />
        </div>

		<div class="fieldset fieldset--submit fieldset--default">
			<button class="full-width has-padding" type="submit">
				Reset password			</button>
		</div>
		<!-- For Invisible Recaptcha plugin -->
		<span class="wpcf7-submit" style="display: none;"></span>

	</form>

	<p class="lrm-form-bottom-message"><a href="#0" class="lrm-switch-to--login">Back to login</a></p>
</div> <!-- lrm-reset-password -->
        </div> <!-- lrm-user-modal-container -->
        <a href="#0" class="lrm-close-form" title="close">
            <span class="lrm-ficon-close"></span>
        </a>

    </div> <!-- lrm-user-modal-container -->

</div> <!-- lrm-user-modal --><script type="text/javascript">var jfla = ["view_counter"]</script><script>window.advanced_ads_check_adblocker=function(t){var n=[],e=null;function i(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}return i((function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),i((function(){var i=window.getComputedStyle&&window.getComputedStyle(t),o=i&&i.getPropertyValue("-moz-binding");e=i&&"none"===i.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var a=0,r=n.length;a<r;a++)n[a](e);n=[]}))})),function(t){null!==e?t(e):n.push(t)}}();</script>				<script>
					(function (i, s, o, g, r, a, m) {
						i['GoogleAnalyticsObject'] = r
						i[r] = i[r] || function () {
							(i[r].q = i[r].q || []).push(arguments)
						}, i[r].l = 1 * new Date()
						a = s.createElement(o),
							m = s.getElementsByTagName(o)[0]
						a.async = 1
						a.src = g
						m.parentNode.insertBefore(a, m)
					})(window, document, 'script', 'https://www.google-analytics.com/analytics.js', 'ga')

					ga('create', 'UA-90858401-1', 'auto')
					ga('send', 'pageview')
				</script>
																			  
			<div id="selectShareContainer">
                        <div class="selectShare-inner">
                            <div class="select_share jeg_share_button">              
                                <button class="select-share-button jeg_btn-facebook" data-url="http://www.facebook.com/sharer.php?u=[url]&quote=[selected_text]" data-post-url="https%3A%2F%2Ffincastleherald.com%2Fplant-swap-in-eagle-rock%2F" data-image-url="" data-title="Plant%20swap%20in%20Eagle%20Rock" ><i class="fa fa-facebook-official"></i></a><button class="select-share-button jeg_btn-twitter" data-url="https://twitter.com/intent/tweet?text=[selected_text]&url=[url]" data-post-url="https%3A%2F%2Ffincastleherald.com%2Fplant-swap-in-eagle-rock%2F" data-image-url="" data-title="Plant%20swap%20in%20Eagle%20Rock" ><i class="fa fa-twitter"></i></a>
                            </div>
                            <div class="selectShare-arrowClip">
                                <div class="selectShare-arrow"></div>      
                            </div> 
                        </div>      
                      </div><div class="jeg_read_progress_wrapper"></div><style>				.single .entry-content {
				display: none;
				}
				</style>	<script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
	<script  src="https://fincastleherald.com/wp-content/cache/minify/16/d07ea.js"></script>

<script type='text/javascript' id='lrm-modal-js-extra'>
/* <![CDATA[ */
var LRM = {"home_url_arr":{"scheme":"https","host":"fincastleherald.com"},"home_url":"https:\/\/fincastleherald.com","password_zxcvbn_js_src":"https:\/\/fincastleherald.com\/wp-includes\/js\/zxcvbn.min.js","allow_weak_password":"","password_strength_lib":null,"redirect_url":"","ajax_url":"https:\/\/fincastleherald.com\/?lrm=1","is_user_logged_in":"","reload_after_login":null,"selectors_mapping":{"login":"a[href*='wp-login']","register":""},"is_customize_preview":"","l10n":{"password_is_good":"Good Password","password_is_strong":"Strong Password","password_is_short":"Too Short Password","password_is_bad":"Bad Password","passwords_is_mismatch":"Passwords is mismatch!","passwords_is_weak":"Error: Your password is very weak!"}};
/* ]]> */
</script>


<script  src="https://fincastleherald.com/wp-content/cache/minify/16/a16cd.js"></script>

<script type='text/javascript' id='wc-add-to-cart-js-extra'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/fincastleherald.com\/cart\/","is_cart":"","cart_redirect_after_add":"yes"};
/* ]]> */
</script>

<script  src="https://fincastleherald.com/wp-content/cache/minify/16/dc06c.js"></script>

<script type='text/javascript' id='woocommerce-js-extra'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script  src="https://fincastleherald.com/wp-content/cache/minify/16/63a69.js"></script>

<script type='text/javascript' id='wc-cart-fragments-js-extra'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_2a7a35ae2d9412ae40b7c69c73909e1b","fragment_name":"wc_fragments_2a7a35ae2d9412ae40b7c69c73909e1b","request_timeout":"5000"};
/* ]]> */
</script>
<script  src="https://fincastleherald.com/wp-content/cache/minify/16/b4041.js"></script>

<script type='text/javascript' id='metorik-js-js-extra'>
/* <![CDATA[ */
var metorik_params = {"lifetime":"6","session":"30","ajaxurl":"https:\/\/fincastleherald.com\/wp-admin\/admin-ajax.php","cart_tracking":"","cart_items":"0","cart_checkout_button":"1","add_cart_popup_placement":"bottom","send_cart_events":"added_to_cart removed_from_cart updated_cart_totals updated_shipping_method applied_coupon removed_coupon updated_checkout"};
/* ]]> */
</script>

<script  src="https://fincastleherald.com/wp-content/cache/minify/16/284ef.js"></script>

<script type='text/javascript' id='leaky_paywall_cookie_js-js-extra'>
/* <![CDATA[ */
var leaky_paywall_cookie_ajax = {"ajaxurl":"\/wp-admin\/admin-ajax.php","post_container":".entry-content","page_container":"article .entry-content","lead_in_elements":"0"};
/* ]]> */
</script>
<script  src="https://fincastleherald.com/wp-content/cache/minify/16/44269.js"></script>

<script type='text/javascript' id='leaky_paywall_script-js-extra'>
/* <![CDATA[ */
var leaky_paywall_script_ajax = {"ajaxurl":"\/wp-admin\/admin-ajax.php","stripe_pk":"","apple_pay":"no"};
/* ]]> */
</script>



<script  src="https://fincastleherald.com/wp-content/cache/minify/16/7af8a.js"></script>

<script type='text/javascript' id='jnews-frontend-js-extra'>
/* <![CDATA[ */
var jnewsoption = {"login_reload":"https:\/\/fincastleherald.com\/plant-swap-in-eagle-rock","popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","language":"en_US","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"79075","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":"","lang":{"invalid_recaptcha":"Invalid Recaptcha!","empty_username":"Please enter your username!","empty_email":"Please enter your email!","empty_password":"Please enter your password!"},"recaptcha":"0","site_slug":"\/plant-swap-in-eagle-rock\/","site_domain":"fincastleherald.com","zoom_button":"1"};
/* ]]> */
</script>
<script  src="https://fincastleherald.com/wp-content/cache/minify/16/9880d.js"></script>

<!--[if lt IE 9]>
<script type='text/javascript' src='https://fincastleherald.com/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=1.0.0' id='html5shiv-js'></script>
<![endif]-->
<script type='text/javascript' id='advadsTrackingHandle-js-extra'>
/* <![CDATA[ */
var advadsTracking = {"ajaxurl":"https:\/\/fincastleherald.com\/wp-admin\/admin-ajax.php","ajaxActionName":"aatrack-records","method":null,"blogId":"16"};
/* ]]> */
</script>
<script  src="https://fincastleherald.com/wp-content/cache/minify/16/96fd1.js"></script>

<script type='text/javascript' id='advadsTrackingGAFront-js-extra'>
/* <![CDATA[ */
var advadsGALocale = {"Impressions":"Impressions","Clicks":"Clicks"};
/* ]]> */
</script>

<script  src="https://fincastleherald.com/wp-content/cache/minify/16/3ae20.js"></script>

<script type='text/javascript' src='https://js.stripe.com/v3/?ver=4.17.2' id='stripe-js'></script>
<script type='text/javascript' id='jnews-select-share-js-extra'>
/* <![CDATA[ */
var jnews_select_share = {"is_customize_preview":""};
/* ]]> */
</script>
<script  src="https://fincastleherald.com/wp-content/cache/minify/16/9549b.js"></script>

<script>window.advads_passive_groups = {"8789_4":{"type":"group","id":8789,"elementid":["finca-c673bd4dfb31b12c0b0f486f61593c56"],"ads":{"57239":{"id":57239,"title":"Google Vertical Ad","expiry_date":0,"visitors":[],"content":"<div style=\"margin-left: auto; margin-right: auto; text-align: center; \" id=\"finca-230607333\"><script async src=\"\/\/pagead2.googlesyndication.com\/pagead\/js\/adsbygoogle.js?client=ca-pub-4648783079594586\" crossorigin=\"anonymous\"><\/script><ins class=\"adsbygoogle\" style=\"display:block;\" data-ad-client=\"ca-pub-4648783079594586\" \ndata-ad-slot=\"\" \ndata-ad-format=\"auto\"><\/ins>\n<script> \n(adsbygoogle = window.adsbygoogle || []).push({}); \n<\/script>\n<\/div>","once_per_page":0,"debugmode":false,"blog_id":16,"type":"adsense","position":"center","tracking_enabled":true}},"group_info":{"id":8789,"name":"Vertical Ads Homepage","weights":{"57239":1},"type":"ordered","ordered_ad_ids":[57239],"ad_count":1}},"8795_6":{"type":"group","id":8795,"elementid":["finca-62cb9bbd0b6f8f4ec7fbdace6d0e6599"],"ads":{"75975":{"id":75975,"title":"VDH HPV 300x250","expiry_date":1654008600,"visitors":[],"content":"<div style=\"margin-left: auto; margin-right: auto; text-align: center; \" id=\"finca-1575366911\"><a data-bid=\"16\" href=\"https:\/\/fincastleherald.com\/linkout\/75975\" target=\"_blank\"><img loading=\"lazy\" src=\"https:\/\/fincastleherald.com\/wp-content\/uploads\/sites\/16\/2021\/12\/Ad-Digital-WH01-300x250-1.png\" alt=\"\"  class=\"no-lazyload\" width=\"300\" height=\"250\"  style=\"display: inline-block;\" \/><\/a><\/div>","once_per_page":0,"debugmode":false,"blog_id":16,"type":"image","position":"center","tracking_enabled":true}},"group_info":{"id":8795,"name":"VPA HPV","weights":{"75975":10},"type":"default","ordered_ad_ids":[75975],"ad_count":1}}};

window.advads_ajax_queries = [{"id":"after-content","method":"placement","params":{"previous_method":"placement","previous_id":"after-content","url_parameter":"\/plant-swap-in-eagle-rock\/","post":{"id":79075,"author":"3947","post_type":"post"},"wp_the_query":{"term_id":"","taxonomy":"","is_main_query":true,"is_rest_api":false,"page":1,"numpages":1,"is_archive":false,"is_search":false,"is_home":false,"is_404":false,"is_attachment":false,"is_singular":true,"is_front_page":false,"is_feed":false},"placement_type":"post_bottom","output":{"class":["finca-after-content"],"placement_id":"after-content"},"global_output":true},"elementid":"finca-3f930c06df71e2279604e6ab3d6ac710","blog_id":16},{"id":"above-headline","method":"placement","params":{"ad_label":"default","placement_position":"","placement_conditions":{"display":[{"type":"posttypes","operator":"is","value":["post"]}]},"placement":{"type":"post_above_headline"},"previous_method":"placement","previous_id":"above-headline","url_parameter":"\/plant-swap-in-eagle-rock\/","post":{"id":79075,"author":"3947","post_type":"post"},"wp_the_query":{"term_id":"","taxonomy":"","is_main_query":true,"is_rest_api":false,"page":1,"numpages":1,"is_archive":false,"is_search":false,"is_home":false,"is_404":false,"is_attachment":false,"is_singular":true,"is_front_page":false,"is_feed":false},"placement_type":"post_above_headline","output":{"class":["finca-above-headline"],"placement_id":"above-headline"},"change-ad":{"conditions":[{"type":"posttypes","operator":"is","value":["post"],"connector":"and"}]},"global_output":true},"elementid":"finca-e5d37a9fb787bfe63f58ff8358ccc595","blog_id":16}];

window.advads_has_ads = [["77100","ad",null],["43012","ad",null]];

( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( !window.advanced_ads_pro ) {console.log("Advanced Ads Pro: cache-busting can not be initialized");} });</script><div class="jeg_ad jnews_mobile_sticky_ads "></div><script type="text/javascript">;!function(){"use strict";window.jnews=window.jnews||{},window.jnews.first_load=window.jnews.first_load||{},window.jnews.first_load=function(){var e=this,t=jnews.library,n="object"==typeof jnews&&"object"==typeof jnews.library;e.data=null,e.run_ajax=!0,e.run_loginregister=!0,e.clear=function(){e.run_ajax=!0,e.run_loginregister=!0,e.data=null},e.init=function(){n&&(t.globalBody.querySelectorAll(".jeg_popup_account").length&&jnews.loginregister&&e.run_loginregister&&(e.run_loginregister=!1,jnews.loginregister.init(),jnews.loginregister.hook_form()),jfla.length&&e.run_ajax&&(e.run_ajax=!1,e.do_ajax({action:"jnews_first_load_action",jnews_id:jnewsoption.postid,load_action:jfla})))},e.update_counter=function(){if(n){var o={total_view:t.globalBody.querySelectorAll(".jeg_share_stats .jeg_views_count .counts"),total_share:t.globalBody.querySelectorAll(".jeg_share_stats .jeg_share_count .counts"),total_comment:t.globalBody.querySelectorAll(".jeg_meta_comment a span")};t.forEach(Object.entries(e.data.counter),(function([e,n]){o[e].length&&t.forEach(o[e],(function(e,o){t.setText(e,n)}))}))}},e.do_ajax=function(o){if(n){var a=new XMLHttpRequest;a.onreadystatechange=function(){XMLHttpRequest.DONE===a.readyState&&200==a.status&&(e.data=JSON.parse(a.responseText),e.data.counter&&"object"==typeof e.data.counter&&e.update_counter())},a.open("POST",jnews_ajax_url,!0),a.setRequestHeader("Content-Type","application/x-www-form-urlencoded; charset=UTF-8"),a.send(t.httpBuildQuery(o))}}},window.jnews.first_load=new window.jnews.first_load,jnews.first_load.init()}();</script><script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><script type="text/javascript">var advads_tracking_ads = {};var advads_tracking_urls = {"16":"https:\/\/fincastleherald.com\/wp-admin\/admin-ajax.php"};var advads_gatracking_uids = {"16":""};var advads_tracking_methods = {"16":"onrequest"};var advads_tracking_parallel = {"16":false};var advads_tracking_linkbases = {"16":"https:\/\/fincastleherald.com\/linkout\/"};var advads_gatracking_allads = {"16":{"77507":{"title":"Subscribe","target":"https:\/\/fincastleherald.com\/subscribe"},"77100":{"title":"Work A Munters #2","target":"https:\/\/workatmunters.com\/?utm_source=digital&utm_medium=fincastle-herald&utm_campaign=you_matter_at_munters&utm_term=female&utm_content=350x350"},"77098":{"title":"Work A Munters #1","target":"https:\/\/workatmunters.com\/?utm_source=digital&utm_medium=fincastle-herald&utm_campaign=you_matter_at_munters&utm_term=male&utm_content=350x350"},"75981":{"title":"VDH HPV 970x250","target":"https:\/\/www.facebook.com\/VaccinateVirginia\/"},"75979":{"title":"VDH HPV 728x90","target":"https:\/\/www.facebook.com\/VaccinateVirginia\/"},"75977":{"title":"VDH HPV 300x600","target":"https:\/\/www.facebook.com\/VaccinateVirginia\/"},"75975":{"title":"VDH HPV 300x250","target":"https:\/\/www.facebook.com\/VaccinateVirginia\/"},"75464":{"title":"VPA Digital Flu 800x100","target":"https:\/\/vahealthy.org"},"75462":{"title":"VPA Digital Flu 970x250","target":"https:\/\/www.facebook.com\/378707692729618\/posts\/923839208216461\/"},"75459":{"title":"VPA Digital Flu 320x50","target":"https:\/\/vahealthy.org"},"75457":{"title":"VPA Digital Flu 300x250","target":"https:\/\/vahealthy.org\/"},"75454":{"title":"VPA Digital Flu 2782x408","target":"https:\/\/www.facebook.com\/378707692729618\/posts\/923839208216461\/"},"75456":{"title":"VPA Digital Flu 300x600","target":"https:\/\/vahealthy.org"},"75222":{"title":"Did You Know #2","target":"https:\/\/mountainmedianews.com\/mm\/national\/"},"75224":{"title":"Did You Know #3","target":"https:\/\/mountainmessenger.com\/linkout\/61098"},"75226":{"title":"Did You Know #4","target":false},"75228":{"title":"Did You Know #5","target":"https:\/\/fincastleherald.com\/subscribe\/"},"75230":{"title":"Did You Know #6","target":"https:\/\/fincastleherald.com\/subscribe\/"},"75232":{"title":"Did You Know #7","target":false},"75220":{"title":"Did You Know #1","target":"https:\/\/mountainmedianews.com\/mm\/virginia-media-inc\/"},"74692":{"title":"VD Banner 4","target":"https:\/\/www.elections.virginia.gov\/"},"74690":{"title":"VD Banner 3","target":"https:\/\/www.elections.virginia.gov\/"},"74688":{"title":"VD Banner 2","target":"https:\/\/www.elections.virginia.gov\/"},"74686":{"title":"VD Banner 1","target":"https:\/\/www.elections.virginia.gov\/"},"74684":{"title":"VD Vertical 4","target":"https:\/\/www.elections.virginia.gov\/"},"74682":{"title":"VD Vertical 3","target":"https:\/\/www.elections.virginia.gov\/"},"74680":{"title":"VD Square 2","target":"https:\/\/www.elections.virginia.gov\/"},"74678":{"title":"VD Square","target":"https:\/\/www.elections.virginia.gov\/"},"74676":{"title":"VD Vertical 2","target":"https:\/\/www.elections.virginia.gov\/"},"74674":{"title":"VD Elections Vertical 1","target":"https:\/\/www.elections.virginia.gov\/"},"73690":{"title":"Subscribe #3","target":"https:\/\/fincastleherald.com\/subscribe\/"},"73330":{"title":"Subscribe Doodle","target":false},"73163":{"title":"Apex Clean Energy","target":"https:\/\/rockyforgewind.com"},"69958":{"title":"Download Mobile App","target":"https:\/\/mountainmedianews.com\/download-mobile-app\/"},"57766":{"title":"Bank of Fincastle","target":"https:\/\/www.bankoffincastle.bank\/personal-banking\/open-an-account-or-apply-for-a-loan-here-today\/"},"57242":{"title":"Google Review Code","target":false},"57240":{"title":"Google Header Home Page","target":false},"57239":{"title":"Google Vertical Ad","target":false},"56135":{"title":"Ritchfield","target":"https:\/\/richfieldliving.com"},"55789":{"title":"Adsense Tracking","target":false},"51009":{"title":"Don't Cache","target":false},"50106":{"title":"Subscribe #2","target":"https:\/\/fincastleherald.com\/subscribe\/"},"50091":{"title":"Subscribe #1","target":"https:\/\/fincastleherald.com\/subscribe\/"},"50089":{"title":"Visit Mountain Media","target":"https:\/\/mountainmedianews.com\/"},"43012":{"title":"Google Auto Ads","target":false},"42304":{"title":"Private Mode","target":false},"38073":{"title":"Join Community","target":false},"37133":{"title":"Newsletter Ad #3","target":false},"37132":{"title":"Newsletter Ad #2","target":false},"37131":{"title":"Newsletter Ad #1","target":false},"36942":{"title":"Adplugg Ads","target":false},"36941":{"title":"Google Rectangle Ad","target":false},"36939":{"title":"Google Banner Ad","target":false},"36930":{"title":"Support Journalism","target":false}}};var advads_gatracking_anonym = true;</script><script type="text/javascript">
				if ( 'undefined' == typeof window.advadsGATracking ) window.advadsGATracking = {};
                				advadsGATracking.postContext = {"postID":79075,"postSlug":"plant-swap-in-eagle-rock","cats":"featured-2,fh-local-stories"};
                			</script><script>window.w3tc_lazyload=1,window.lazyLoadOptions={elements_selector:".lazy",callback_loaded:function(t){var e;try{e=new CustomEvent("w3tc_lazyload_loaded",{detail:{e:t}})}catch(a){(e=document.createEvent("CustomEvent")).initCustomEvent("w3tc_lazyload_loaded",!1,!1,{e:t})}window.dispatchEvent(e)}}</script><script  async src="https://fincastleherald.com/wp-content/cache/minify/16/1615d.js"></script>
</body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Object Caching 404/489 objects using disk
Page Caching using disk: enhanced 
Lazy Loading
Minified using disk
Database Caching using disk (Request-wide modification query)

Served from: fincastleherald.com @ 2022-04-26 14:15:28 by W3 Total Cache
-->